Ask Your Question
0

Pike install linuxbridge-agent.service failed on Compute

asked 2018-02-12 22:31:44 -0600

tracks345 gravatar image

I inherited a somewhat flaky openstack installation at work so I’m trying to go through the install to understand how these things work. I pulled 3 boxes out of inventory and am working my way through it.

Each box is has enp0s25 and enp0s20u1. enp0s25 is on the management network, enp0s20u1 is plugged into a hub which is connected to the enp0s25 interface on the other boxes. I’m not sure if this is correct or not. Please correct me if this sounds wrong.

I installed Centos on all the machines and have been proceeding through the installation everything went fine (well, I worked through all the errors) until I hit this one. I’ve gone through the results on this site and found similar issues but not found the resolution for this.

I’ve gone through the config files in the instructions (https://docs.openstack.org/neutron/pike/install/install-rdo.html (https://docs.openstack.org/neutron/pi...)) multiple times, but I must be missing something. I’ve followed the instructions to the letter (I think) with the exception of the ip address on the mgmt. network (to make my routing easier).

I followed the steps for self service networks (don’t fully understand the difference though), because that's what the work configuration is.

On Controller: enp0s25 has IP 192.168.1.186, enp0s25 has no IP neutron agent-list shows that these are all running on controller. • DHCP agent • Linux bridge agent • Metadata agent • L3 agent

On Compute1: enp0s25 has IP 192.168.1.187, enp0s25 has no IP $ neutron agent-list Connection to neutron failed: Failed to connect Neutron server. (I had to open a firewall port 35357 on controller to get it this far) Should this work?

So there’s that, but linuxbridge agent can’t start:

$ systemctl status neutron-linuxbridge-agent.service neutron-linuxbridge-agent.service - OpenStack Neutron Linux Bridge Agent Loaded: loaded (/usr/lib/systemd/system/neutron-linuxbridge-agent.service; enabled; vendor preset: disabled) Active: failed (Result: start-limit) since Mon 2018-02-12 21:16:52 EST; 38min ago Process: 4514 ExecStart=/usr/bin/neutron-linuxbridge-agent --config-file /usr/share/neutron/neutron-dist.conf --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugins/ml2/linuxbridge_agent.ini --config-dir /etc/neutron/conf.d/common --config-dir /etc/neutron/conf.d/neutron-linuxbridge-agent --log-file /var/log/neutron/linuxbridge-agent.log (code=exited, status=1/FAILURE) Process: 4508 ExecStartPre=/usr/bin/neutron-enable-bridge-firewall.sh (code=exited, status=0/SUCCESS) Main PID: 4514 (code=exited, status=1/FAILURE)

Feb 12 21:16:52 compute1 systemd[1]: Unit neutron-linuxbridge-agent.service entered failed state. Feb 12 21:16:52 compute1 systemd[1]: neutron-linuxbridge-agent.service failed. Feb 12 21:16:52 compute1 systemd[1]: neutron-linuxbridge-agent.service holdoff time over, scheduling restart. Feb 12 21:16:52 compute1 systemd[1]: start request repeated too quickly for neutron-linuxbridge-agent.service Feb 12 21:16:52 compute1 systemd[1]: Failed to start OpenStack Neutron Linux Bridge Agent. Feb 12 21:16:52 compute1 systemd[1]: Unit neutron-linuxbridge-agent.service entered failed state. Feb 12 21:16:52 compute1 systemd[1]: neutron-linuxbridge-agent.service failed ... (more)

edit retag flag offensive close merge delete

Comments

I fixed the Connection to Neutron problem by opening the firewall port 9696 on the controller. Linuxbridge agent still not starting though

tracks345 gravatar imagetracks345 ( 2018-02-15 12:48:29 -0600 )edit

OK I think I may have solved this. The documentation says to use the IP of the controller, in the linuxbridge.ini, but the when I put the IP of the Management interface of the Compute node in it worked.

Maybe an error in the docs?

tracks345 gravatar imagetracks345 ( 2018-02-15 14:13:36 -0600 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2018-03-12 08:10:54 -0600

tracks345 gravatar image

Using the IP address of the compute node fixed it.

edit flag offensive delete link more

Comments

You have to differentiate between the services referring to control or compute nodes, so read the instructions very carefully, you may stumble upon this kind of issue several times. The docs usually cover this difference pretty good, but you really have to read thoroughly. Keep going! :-)

eblock gravatar imageeblock ( 2018-03-13 04:27:23 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-02-12 22:31:44 -0600

Seen: 188 times

Last updated: Mar 12