Ask Your Question
0

Could not create VLAN (VlanAllocation is not mapped error)

asked 2018-02-12 10:06:34 -0600

yas gravatar image

updated 2018-02-14 03:41:37 -0600

I installed Openstack RDO recently and I am able to launch instances with tenant_network_types=vxlan everything works good (ping, ssh ...). I need to create VLANs so I did the following configuration:

/etc/neutron/plugins/ml2/ml2_conf.ini file: (The portion that I changed)

[ml2]
type_drivers=vxlan,vlan,flat
tenant_network_types=vxlan,vlan
mechanism_drivers=openvswitch
[ml2_type_vlan]
 network_vlan_ranges =extnet:100:200

[ml2_type_vxlan]
vni_ranges=10:100
vxlan_group=224.0.0.1

/etc/neutron/plugins/ml2/openvswitch_agent.ini file (I did not change it)

[ovs]
bridge_mappings=extnet:br-ex

After the changes made on /etc/neutron/plugins/ml2/ml2_conf.ini I could not restart neutron:

sudo service neutron-server restart

RESULT:

Redirecting to /bin/systemctl restart neutron-server.service
Job for neutron-server.service failed because the control process exited with error code. See "systemctl status neutron-server.service" and "journalctl -xe" for details.


Feb 12 16:58:15 localhost.localdomain neutron-server[11967]: Guru meditation now registers SIGUSR1 and SIGUSR2 by default for backward compatibilit
Feb 12 16:58:18 localhost.localdomain systemd[1]: neutron-server.service: main process exited, code=exited, status=1/FAILURE
Feb 12 16:58:18 localhost.localdomain systemd[1]: Failed to start OpenStack Neutron Server.
-- Subject: Unit neutron-server.service has failed

After consulting the neutron log files I found this error:

'neutron.objects.plugins.ml2.vlanallocation.VlanAllocation' is not mapped

Thank you

edit retag flag offensive close merge delete

Comments

Hi, This might not be correct, but what i saw in the https://docs.openstack.org/neutron/pike/admin/deploy-ovs-provider.html (https://docs.openstack.org/neutron/pi...) in the note, it says that "The tenant_network_types option contains no value because the architecture does not support self-service networks."

mike11 gravatar imagemike11 ( 2018-02-12 10:17:57 -0600 )edit

Check the neutron server log for more details: journalctl -u neutron-server.

Bernd Bausch gravatar imageBernd Bausch ( 2018-02-12 17:33:20 -0600 )edit

I tried to leave tenant_network_types empty but the same thing neutron cannot be restarted

yas gravatar imageyas ( 2018-02-13 09:00:27 -0600 )edit

A bug with the Vlanallocation error has been filed recently: https://bugs.launchpad.net/neutron/+b....

Bernd Bausch gravatar imageBernd Bausch ( 2018-02-14 06:00:58 -0600 )edit

Yes I consulted it. It seems that we need to run packstack (during the installation process) with the option --os-neutron-ml2-type-drivers=vxlan,flat,vlan not sure but I will confirm after trying it in the next few hours

yas gravatar imageyas ( 2018-02-14 07:42:02 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-02-15 05:11:11 -0600

yas gravatar image

I resolved the issue by reinstalling openstack through packstack and specifying the keyword vlan in the command option or by manually specifying the type drivers in the generated answer file:

packstack --allinone --provision-demo=n --os-neutron-ovs-bridge-mappings=extnet:br-ex --os-neutron-ovs-bridge-interfaces=br-ex:eth0 --os-neutron-ml2-type-drivers=vxlan,flat,vlan

I tried to create a VLAN and it works fine. I hope this answer will help someone in the future. :)

edit flag offensive delete link more

Comments

I recently encountered the same problem. Deleting all entries from ml2_vlan_allocations (or similar name) in the neutron database fixed it for me

jsm gravatar imagejsm ( 2018-02-16 06:48:27 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-02-12 10:06:34 -0600

Seen: 42 times

Last updated: Feb 15