metadata provider network

asked 2018-02-08 15:59:33 -0500

cbravo gravatar image

Hello,

I have openstack Pike configured on three nodes - 1 Controller Node & 2 Compute nodes. I have made it up to the point where the instance can get a DHCP Lease from the control node, however it cannot get metadata from the control node.

Also, I am using PROVIDER Network.

    [root@scoscontrol01 ~]# openstack network agent list
+--------------------------------------+--------------------+---------------------------+-------------------+-------+-------+---------------------------+
| ID                                   | Agent Type         | Host                      | Availability Zone | Alive | State | Binary                    |
+--------------------------------------+--------------------+---------------------------+-------------------+-------+-------+---------------------------+
| 6f7b7297-b452-4a54-9aeb-0eac7b40e47d | Linux bridge agent | oscmp01    | None              | :-)   | UP    | neutron-linuxbridge-agent |
| c5d95cfe-a76d-4148-aebe-97030d7b12fd | Linux bridge agent | oscmp02     | None              | :-)   | UP    | neutron-linuxbridge-agent |
| cb8986e3-787e-4207-9895-41b89c750fcb | Metadata agent     | oscontrol01 | None              | :-)   | UP    | neutron-metadata-agent    |
| cfc37511-957d-4d01-945d-6ad7e72b5333 | DHCP agent         | oscontrol01 | nova              | :-)   | UP    | neutron-dhcp-agent        |
| e7deab71-ffcf-4875-ae8e-e9324e3cce4a | Linux bridge agent | oscontrol01 | None              | :-)   | UP    | neutron-linuxbridge-agent |
+--------------------------------------+--------------------+---------------------------+-------------------+-------+-------+---------------------------+

Looking at the instance logs, it tries to reach 169.254.169.254, but it fails. After that, it tries to reach the default gateway and fails. Any ideas as to what I'm missing? Where should I be looking for logs or clues as to what is going on? Without metadata service, I cannot inject SSH Keys.

Second question, after every test is done the instances will use non routable VLAN's (kind of a VLAN a Customer scenario). Do I need to have reachability to the metadata service on the control node from the instance or is that something handled by the compute node on the back?

Thank you so much in advance for any help or tip you can give me.

edit retag flag offensive close merge delete

Comments

i have same problem any help netstat -tpa

tcp 0 0 169.254.169.254:http 172.16.241.75:49704 SYN_RECV - getnameinfo failed

rootroot gravatar imagerootroot ( 2018-04-05 11:14:09 -0500 )edit