Ask Your Question
0

issue(no precheck.yml present) with ovs-dpdk in kolla ansible pike version

asked 2018-01-24 00:18:07 -0500

akarki gravatar image

The current stable/pike version of kolla ansible does not have precheck.yml in ovs-dpdk roles folder which causes prechecks to fail.

Other issues include:

/usr/local/share/kolla-ansible/ansible/roles/ovs-dpdk/tasks/config.yml file line 24 task:

- name: Copying ovs-dpdkctl tool
  copy:
    src: ../tools/ovs-dpdkctl.sh
    dest: "{{ node_config_directory }}/ovsdpdk-db/ovs-dpdkctl.sh"
    mode: 0777

 uses relative path but at this source path no ovs-dpdkctl.sh is present.

However, this issue was resolved as script was present in kolla-ansible code.

Another issue during deployment is:

we have set huge pages in grub file as:

  GRUB_CMDLINE_LINUX="default_hugepagesz=2M hugepagesz=2M hugepages=250

also added all the parametes in /etc/kolla/globals.yml:

ovs_datapath: "netdev"
enable_ovs_dpdk: yes
enable_openvswitch: yes
tunnel_interface: "dpdk_bridge"
neutron_bridge_name: "dpdk_bridge"

globals.yml: http://paste.openstack.org/show/651483/

During deployment it throws error:

TASK [neutron : Copying over ml2_conf.ini] ****************************************************************************************************************************
skipping: [localhost] => (item={'key': u'neutron-dhcp-agent', 'value': {u'group': u'neutron-dhcp-agent', u'image': u'172.16.141.20:4000/kolla/ubuntu-source-neutron-dhcp-agent:5.0.2', u'enabled': True, u'host_in_groups': True, u'volumes': [u'/etc/kolla//neutron-dhcp-agent/:/var/lib/kolla/config_files/:ro', u'/etc/localtime:/etc/localtime:ro', u'/run/:/run/:shared', u'neutron_metadata_socket:/var/lib/neutron/kolla/', u'kolla_logs:/var/log/kolla/'], u'container_name': u'neutron_dhcp_agent', u'privileged': True}})
skipping: [localhost] => (item={'key': u'neutron-linuxbridge-agent', 'value': {u'image': u'172.16.141.20:4000/kolla/ubuntu-source-neutron-linuxbridge-agent:5.0.2', u'enabled': False, u'host_in_groups': True, u'environment': {u'NEUTRON_INTERFACE': u'enp6s0f0', u'KOLLA_CONFIG_STRATEGY': u'COPY_ALWAYS', u'NEUTRON_BRIDGE': u'br-ex'}, u'volumes': [u'/etc/kolla//neutron-linuxbridge-agent/:/var/lib/kolla/config_files/:ro', u'/etc/localtime:/etc/localtime:ro', u'/lib/modules:/lib/modules:ro', u'/run:/run:shared', u'kolla_logs:/var/log/kolla/'], u'container_name': u'neutron_linuxbridge_agent', u'privileged': True}})
skipping: [localhost] => (item={'key': u'neutron-bgp-dragent', 'value': {u'group': u'neutron-bgp-dragent', u'image': u'172.16.141.20:4000/kolla/ubuntu-source-neutron-bgp-dragent:5.0.2', u'enabled': False, u'host_in_groups': True, u'volumes': [u'/etc/kolla//neutron-bgp-dragent/:/var/lib/kolla/config_files/:ro', u'/etc/localtime:/etc/localtime:ro', u'/run:/run:shared', u'kolla_logs:/var/log/kolla/'], u'container_name': u'neutron_bgp_dragent', u'privileged': True}})
skipping: [localhost] => (item={'key': u'neutron-vpnaas-agent', 'value': {u'group': u'neutron-vpnaas-agent', u'image': u'172.16.141.20:4000/kolla/ubuntu-source-neutron-vpnaas-agent:5.0.2', u'enabled': False, u'host_in_groups': True, u'volumes': [u'/etc/kolla//neutron-vpnaas-agent/:/var/lib/kolla/config_files/:ro', u'/etc/localtime:/etc/localtime:ro', u'/run:/run:shared', u'/lib/modules:/lib/modules:ro', u'kolla_logs:/var/log/kolla/'], u'container_name': u'neutron_vpnaas_agent', u'privileged': True}})


**fatal: [localhost]: FAILED! => {"failed": true, "msg": "{{ hostvars[inventory_hostname]['ansible_' + tunnel_interface]['ipv4']['address'] }}: 'dict object' has no attribute u'ansible_dpdk_bridge'"}**

we have given tunnel interface as dpdk_bridge .do we need to give it as an already present interface (in my case"enp6s0f0") or do we need to create a virtual interface ourseleves

Please help

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-03-15 11:43:06 -0500

nahian gravatar image

updated 2018-03-15 11:45:46 -0500

Which one is your external bridge (br-ex) ? In ml2_conf.ini (/etc/kolla/neutron-openvswitch-agent/) it is somewhere written br-ex is mapped to physnet1, Im not sure, if your dpdk_bridge is your external bridge inside your network node(s).

[ovs]
bridge_mappings = physnet1:br-ex
datapath_type = system
ovsdb_connection = tcp:127.0.0.1:6640
local_ip =

Where exactly did you find the neutron_bridge_name in global.yml file? Is it that neutron_external_interface or?

edit flag offensive delete link more

Comments

Problem is the included file is named prechecks.yml and should have been named precheck.yml Rename it and it going to work.

jmguzman gravatar imagejmguzman ( 2018-05-27 22:25:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-01-24 00:18:07 -0500

Seen: 309 times

Last updated: Mar 15 '18