Ask Your Question
0

Interfaces created by kolla in DOWN/UNKNOWN state

asked 2018-01-23 16:13:41 -0500

holo gravatar image

updated 2018-01-23 18:27:02 -0500

Hello

All interfaces created by Kolla after installation are in DOWN state. When i try manually set them up they are changing to UNKNOWN. Can it be that im using systemd-networkd for seeting up my main interfaces? If not, how can i fix it? What can i check?

EDIT:

When i try to start normal instance instead of router im getting such error in neutron and nova:

2018-01-24 01:17:24.589 28 ERROR neutron.plugins.ml2.managers [req-8751f883-f9dd-43d1-ab5c-ea9d85813df3 6e758d916f514fe6978304c1558bcfe7 367730891853403bb40d8f00dfc57d6b - default default] Failed to bind port 5195df11-9719-4387-8a21-e7333bcde630 on host compute00 for vnic_type normal using segments [{'network_id': '8302585c-7543-4414-b01c-0437878cf8f5', 'segmentation_id': None, 'physical_network': u'physnet1', 'id': '19da16de-701c-4d2d-b7e1-7d97b1a9279a', 'network_type': u'flat'}]
2018-01-24 01:17:24.590 28 INFO neutron.plugins.ml2.plugin [req-8751f883-f9dd-43d1-ab5c-ea9d85813df3 6e758d916f514fe6978304c1558bcfe7 367730891853403bb40d8f00dfc57d6b - default default] Attempt 2 to bind port 5195df11-9719-4387-8a21-e7333bcde630
2018-01-24 01:17:24.617 28 ERROR neutron.plugins.ml2.managers [req-8751f883-f9dd-43d1-ab5c-ea9d85813df3 6e758d916f514fe6978304c1558bcfe7 367730891853403bb40d8f00dfc57d6b - default default] Failed to bind port 5195df11-9719-4387-8a21-e7333bcde630 on host compute00 for vnic_type normal using segments [{'network_id': '8302585c-7543-4414-b01c-0437878cf8f5', 'segmentation_id': None, 'physical_network': u'physnet1', 'id': '19da16de-701c-4d2d-b7e1-7d97b1a9279a', 'network_type': u'flat'}]

/EDIT

root@controller00 network]# ip l
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eno1: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc mq master bond0 state UP mode DEFAULT qlen 1000
    link/ether 00:1e:4f:2f:b1:57 brd ff:ff:ff:ff:ff:ff
3: eno2: <NO-CARRIER,BROADCAST,MULTICAST,SLAVE,UP> mtu 1500 qdisc mq master bond0 state DOWN mode DEFAULT qlen 1000
    link/ether 00:1e:4f:2f:b1:57 brd ff:ff:ff:ff:ff:ff
4: bond0: <BROADCAST,MULTICAST,MASTER,UP,LOWER_UP> mtu 1500 qdisc noqueue master ovs-system state UP mode DEFAULT qlen 1000
    link/ether 00:1e:4f:2f:b1:57 brd ff:ff:ff:ff:ff:ff
5: vlan60@bond0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT qlen 1000
    link/ether 2e:7d:7c:81:83:1b brd ff:ff:ff:ff:ff:ff
6: vlan70@bond0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT qlen 1000
    link/ether be:7f:83:4f:21:69 brd ff:ff:ff:ff:ff:ff
7: vlan20@bond0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT qlen 1000
    link/ether ea:8e:c4:e9:71:9d brd ff:ff:ff:ff:ff:ff
8: vlan10@bond0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT qlen 1000
    link/ether 02:c1:b0:3c:c8:13 brd ff:ff:ff:ff:ff:ff
9: vlan50@bond0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT qlen 1000
    link/ether 26:5a:c4:d3:46:21 brd ff:ff:ff:ff:ff:ff
10: vlan40@bond0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DEFAULT qlen 1000
    link/ether fe:2b:9a:62:ad:c7 brd ff:ff:ff:ff:ff ...
(more)
edit retag flag offensive close merge delete

Comments

Can you add your globals.yml and nova compute logs?

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2018-01-24 01:23:55 -0500 )edit

Here are is my global file: https://pastebin.com/ew66SaG2

Errors from controller server https://pastebin.com/Z7cPQYYT

Errors from compute server: https://pastebin.com/WUam0z29

What i mention, when i start instance with internal interface it is starting normaly.

holo gravatar imageholo ( 2018-01-24 03:16:59 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-01-30 20:03:50 -0500

holo gravatar image

After one week of fighting with it i finally find out "issue".

By default Kolla configuration is using only private networking and is not creating external bridge "br-ex" on compute instances so there is no posibility to bind port to public network. I solved it by enabling DVR in global file:

enable_neutron_dvr: "yes"

edit flag offensive delete link more

Comments

i actually did this but it did not solve the problem, here's the link of my question https://ask.openstack.org/en/question...

vblando gravatar imagevblando ( 2019-04-14 02:16:10 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-01-23 16:13:41 -0500

Seen: 133 times

Last updated: Jan 30 '18