Devstack ocata shared physical/external network not working

asked 2018-01-23 05:47:24 -0500

send2vijaybe gravatar image

I need to have external network to be shared across the openstack instance , Used devstack installation on ubuntu with single interface on virtual box.

i followed the link https://docs.openstack.org/devstack/latest/networking.html (https://docs.openstack.org/devstack/l...)

I have used the following configuration

RAM: 4 GB Processor: 3 ROM: 20 GB OS: Ubuntu 16.04 Network interface: 1 (Bridge adapter)

I tried installing the openstack devstack with the local.conf file

[[local|localrc]]
ADMIN_PASSWORD=password123
DATABASE_PASSWORD=$ADMIN_PASSWORD
RABBIT_PASSWORD=$ADMIN_PASSWORD
SERVICE_PASSWORD=$ADMIN_PASSWORD
PUBLIC_INTERFACE=enp0s8
HOST_IP=10.0.15.28
FLOATING_RANGE=10.0.15.28/24
PUBLIC_NETWORK_GATEWAY=10.0.15.1
Q_FLOATING_ALLOCATION_POOL=start=10.0.15.120,end=10.0.15.150


#Enable heat services
enable_service h-eng h-api h-api-cfn h-api-cw

#Enable heat plugin
enable_plugin heat https://git.openstack.org/openstack/heat stable/ocata

Installed the devstack version of openstack by stack.sh and I that results connectivity broke to ubuntu and physical machine. Installation also failed in between.

Kindly help me on getting the openstack instance to be part of the external world. what went wrong in this configuration.

edit retag flag offensive close merge delete

Comments

Can you elaborate what you mean with connectivity broke to ubuntu and physical machine?

I have had problems connecting instances in a VirtualBox VM to the outside world. KVM VMs work better in my experience.

Bernd Bausch gravatar imageBernd Bausch ( 2018-01-24 02:55:20 -0500 )edit

my physical machine have the ip as 10.0.15.15 and the ubuntu ip is 10.0.15.28. Before i start the stack.sh it is pingable, after few component installation the connectivity is getting lost and ubuntu becomes a isolated one.

I am using below setup windows >ubuntu(virtualboxt instance) > openstack

send2vijaybe gravatar imagesend2vijaybe ( 2018-01-24 04:11:32 -0500 )edit