Kolla-build failures on base_arch=aarch64

asked 2018-01-23 02:43:39 -0500

gitit gravatar image

I'm trying to build container images locally with base architecture aarch64, using kolla-build. This is in order to deploy Openstack on ARM64. Some necessary images are failing with errors, mainly nova-compute and fluentd:

for nova-compute: # kolla-build nova-compute --base centos --base-arch aarch64 --registry localhost:5000 --push

INFO:kolla.image.build.nova-compute:Error: Package: 1:openstack-nova-compute-16.0.3-2.el7.noarch (delorean-pike-testing) INFO:kolla.image.build.nova-compute: Requires: qemu-kvm-rhev >= 2.9.0

Note: when trying to build nova-compute again but adding "--type source" the build succeeded, so just the binary build is problematic for nova-compute.

for fluentd: #kolla-build fluentd --base centos --base-arch aarch64 --registry localhost:5000 --push

INFO:kolla.image.build.fluentd:Error: Package: fluentd-0.12.41-2.el7.noarch (aarch64-opstools) INFO:kolla.image.build.fluentd: Requires: rubygem(http_parser.rb) >= 0.5.1 INFO:kolla.image.build.fluentd:Error: Package: fluentd-0.12.41-2.el7.noarch (aarch64-opstools) INFO:kolla.image.build.fluentd: Requires: rubygem(msgpack) < 2 INFO:kolla.image.build.fluentd:Error: Package: fluentd-0.12.41-2.el7.noarch (aarch64-opstools) INFO:kolla.image.build.fluentd: Requires: rubygem(cool.io) >= 1.2.2 INFO:kolla.image.build.fluentd:Error: Package: fluentd-0.12.41-2.el7.noarch (aarch64-opstools) INFO:kolla.image.build.fluentd: Requires: rubygem(cool.io) < 2.0.0 INFO:kolla.image.build.fluentd: INFO:kolla.image.build.fluentd:Error: Package: fluentd-0.12.41-2.el7.noarch (aarch64-opstools) INFO:kolla.image.build.fluentd: Requires: rubygem(http_parser.rb) < 0.7.0 INFO:kolla.image.build.fluentd:Error: Package: fluentd-0.12.41-2.el7.noarch (aarch64-opstools) INFO:kolla.image.build.fluentd: Requires: rubygem(string-scrub) <= 0.0.5 INFO:kolla.image.build.fluentd:Error: Package: fluentd-0.12.41-2.el7.noarch (aarch64-opstools) INFO:kolla.image.build.fluentd: Requires: rubygem(yajl-ruby) < 2 INFO:kolla.image.build.fluentd:Error: Package: fluentd-0.12.41-2.el7.noarch (aarch64-opstools) INFO:kolla.image.build.fluentd: Requires: rubygem(msgpack) >= 0.5.11 INFO:kolla.image.build.fluentd:Error: Package: fluentd-0.12.41-2.el7.noarch (aarch64-opstools) INFO:kolla.image.build.fluentd: Requires: rubygem(string-scrub) >= 0.0.3 INFO:kolla.image.build.fluentd: INFO:kolla.image.build.fluentd:Error: Package: fluentd-0.12.41-2.el7.noarch (aarch64-opstools) INFO:kolla.image.build.fluentd: Requires: rubygem(yajl-ruby) >= 1.0

Note: here building with type source didn't help...

Any help would be appreciated.

Thanks, Gitit.

edit retag flag offensive close merge delete