Ask Your Question
0

change MTU value in neutron

asked 2018-01-19 14:32:05 -0500

CloudEnthusiast gravatar image

Hi All,

I have RHOSP10 deployed with undercloud, overcloud in HA fashion using 3 controllers, 3 compute nodes, 3 Ceph Storage nodes. Everything just works fine. I have an use case to change the MTU value at the neutron level - for the OVS bridges so as to reflect the new MTU value for any new VM created). How to achieve this ? What will be the consequence which needs to be taken care ? Please suggest

Any sort of help is appreciated.

--Regards

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2018-01-24 00:17:22 -0500

to Update the MTU size you also need to reconfigure the switches for the larger MTU size that could be 9000.

edit flag offensive delete link more
0

answered 2018-01-22 20:27:26 -0500

CloudEnthusiast gravatar image

Hi All, Let me put here a workaround what i worked in my case. On all 3 overcloud-controller nodes, i changed the parameter

global_physnet_mtu=<NEW-MTU-VALUE>

value in /etc/neutron/neutron.conf. Later i restarted neutron server as below:

systemctl restart neutron-server.service

With this, the all exisiting neutron networks got the new MTU also the newly created networks were with new MTU.

--Regards

edit flag offensive delete link more

Comments

At the switch end , the network admin has enabled jumbo frames already.

CloudEnthusiast gravatar imageCloudEnthusiast ( 2018-03-05 20:44:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-01-19 14:32:05 -0500

Seen: 1,830 times

Last updated: Jan 22 '18