keystone error apt-get upgrade packages version

asked 2018-01-15 04:49:18 -0500

gsic-emic gravatar image

Good Morning,

I wanted to comment on a problem that has happened to me several times ...

I had the OpenStack version "Newton" recently and I updated the OpenStack version "Pike", and all right until the keystone in the controller node did not work well for me as it told me in horizon:

"An error occurred authenticating. Please try again later."

In cli command line: Failed to discover available identity versions when contacting http: // controller: 35357 / v3. Attempting to parse version from URL. Internal Server Error (HTTP 500)

In the end I had to do a clean installation of the controller node.

But just a week ago I decided to update the packages because there were updates and bug fixes in some of them and the same error was shown again.

Horizon:

"An error occurred authenticating. Please try again later."

In cli command line:

Failed to discover available identity versions when contacting http: // controller: 35357 / v3. Attempting to parse version from URL. Internal Server Error (HTTP 500)

Does anyone know why something like this happens every time an apt-get upgrade is done?

Greetings and thanks in advance,

edit retag flag offensive close merge delete