How to change which host glance services will run on

asked 2018-01-09 23:09:40 -0600

jcorkey gravatar image

I used kolla and kolla-ansible 5.0.0 to deploy openstack. I currently have one control node and one compute node. Below is info of my multimode inventory file.

[control]
# These hostname must be resolvable from your deployment host
openstackcontroller

# The network nodes are where your l3-agent and loadbalancers will run
# This can be the same as a host in the control group
[network]
openstackcontroller

[compute]
openstackcompute

[monitoring]
openstackcontroller

# When compute nodes and control nodes use different interfaces,
# you can specify "api_interface" and other interfaces like below:
#compute01 neutron_external_interface=eth0 api_interface=em1 storage_interface=em1 tunnel_interface=em1

[storage]
openstackcontrol

[deployment]
localhost       ansible_connection=local api_interface=enp5s0

If I wanted to add a third node to have all of the storage services like below

[storage]
openstackstorage

Could I also have all glance services run on the storage node instead of the control node? The reason I would like to do this is so that I can create snapshots and add images in my environment and they will be stored on my storage node that I plan to add. Right now all my snapshots I create and images that I create get stored in /var/lib/docker/volumes/_data/glance/images on my control node which is running out of space. So if I changed glance services to run on my storage node, would all of glance images and snapshots be stored on the storage in /var/lib/docker/volumes/_data/glance/images instead of my control node?

My multimode inventory file contains this

[glance:children]
control

If my multimode inventory file specified the [storage] attribute to be like below

[storage]
openstackstorage

Would I simply change

[glance:children]
control

to be

[glance:children]
storage

in order for all glance services to run on openstackstorage node

edit retag flag offensive close merge delete

Comments

I dont get your question :/, you already answered yourself ,), changing to storage group will do it

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2018-01-10 01:31:12 -0600 )edit

I applied these changes but now I am having this problem which I posted here:

https://ask.openstack.org/en/question...

jcorkey gravatar imagejcorkey ( 2018-01-12 16:47:41 -0600 )edit