Ask Your Question
0

enable “memory.usage”, “disk.device.usage” meter

asked 2018-01-09 06:28:17 -0500

selvaraj.chennappan gravatar image

How to enable “memory.usage”, “disk.device.usage” in openstack (ceilometer/nova)

need to get those meter for every 10 minutes (600 secs)

Details :-

Compiled against library: libvirt 1.2.17 Using library: libvirt 1.2.17 Using API: QEMU 1.2.17 Running hypervisor: QEMU 2.6.0

I am new to openstack . Hence could you please post detailed answer/configuration.

edit retag flag offensive close merge delete

Comments

See the installation guide at https://docs.openstack.org/ceilometer.... Depending on the way your cloud is deployed, it may be applied as-is, or you may have to adapt it to your situation.

600 sec is the default sampling interval.

Bernd Bausch gravatar imageBernd Bausch ( 2018-01-10 03:46:22 -0500 )edit

Thanks Bernd. memory.usage and disk.device.usage is not configured in pipeline.yaml or nova.conf. I want to know, how to configure those parameters and enable it at openstack level. so that i can query from application for every 600 sec. as of now I can query cpu_util .

selvaraj.chennappan gravatar imageselvaraj.chennappan ( 2018-01-10 05:04:16 -0500 )edit

Metrics are never configured in nova.conf. Memory usage and disk usage are built into Ceilometer, so that you should not have to configure them in pipeline.yaml either. The installation guide should be sufficient.

Bernd Bausch gravatar imageBernd Bausch ( 2018-01-15 20:06:41 -0500 )edit

Are you using gnocchi or mongodb?

pablobrunetti gravatar imagepablobrunetti ( 2018-01-18 19:27:48 -0500 )edit

mongodb. I want to get disk.device.usage in percentage.

selvaraj.chennappan gravatar imageselvaraj.chennappan ( 2018-01-20 01:36:49 -0500 )edit

1 answer

Sort by » oldest newest most voted
1

answered 2018-01-17 07:51:52 -0500

selvaraj.chennappan gravatar image

updated 2018-01-18 08:51:24 -0500

I have configured memory usage in pipeline.yaml sources:

[...]
- name: memory_source
      interval: 600
      meters:
          - "memory.usage"
      sinks:
          - memory_sink
sinks:
[...]
- name: memory_sink
      transformers:
          - name: "arithmetic"
            parameters:
                target:
                    name: "memory_usage"
                    unit: "%"
                    type: "gauge"
                    expr: "100 * $(memory.usage) / ($(memory.usage).resource_metadata.memory_mb)"

However I am unable to get disk.device.usage

edit flag offensive delete link more

Comments

Disk.device.usage and memory.usageare built into Ceilometer, see https://docs.openstack.org/ceilometer.... There is nothing you need to do to enable them, except possibly the configuration as documented in the installation guide.

Bernd Bausch gravatar imageBernd Bausch ( 2018-01-19 19:34:47 -0500 )edit

What makes you think that they are not enabled?

Bernd Bausch gravatar imageBernd Bausch ( 2018-01-19 19:35:13 -0500 )edit

requirement is to get the disk.device.usage in percentage.I have no idea how to do that in pipeline.yaml. But i have done it for memory usage . I have tried same for disk.device.usage and it is not working. disk.device.usage is not coming in the command $ ceilometer meter-list using mongodb

selvaraj.chennappan gravatar imageselvaraj.chennappan ( 2018-01-20 01:35:55 -0500 )edit

I have no experience crafting pipeline transformers.

Perhaps the meter-list command only prints a limited number of meters. To reduce the output, try a query as documented in https://docs.openstack.org/ceilometer....

Bernd Bausch gravatar imageBernd Bausch ( 2018-01-20 06:42:02 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-01-09 00:59:17 -0500

Seen: 220 times

Last updated: Jan 18