Ask Your Question
0

Failed to install openstack Pike using packstack on Centos 7

asked 2018-01-08 17:48:45 -0500

ahfouad gravatar image

updated 2018-01-21 15:31:46 -0500

Below Error appears:

Error: Evaluation Error: Error while evaluating a Function Call, no address for at /var/tmp/packstack/1028b99b06f84cd1825007235a5aba9a/modules/packstack/manifests/neutron/ovs_agent.pp:50:27 on node localhost

edit retag flag offensive close merge delete

Comments

The error seems to indicate a missing tunnel interface for VXLAN.

Provide more info. Did you follow https://www.rdoproject.org/install/pa... What is the network config of the host, what is the answer file?

Bernd Bausch gravatar imageBernd Bausch ( 2018-01-21 15:31:20 -0500 )edit

i had the same error but it was fixed. below is what i did

rhel7 give fqdn as the host name rename network device to eth0 and modify grub config setenforce 0 in the answer file, dont edit any neutron options

ANAND gravatar imageANAND ( 2018-01-28 11:56:24 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2018-01-27 04:52:58 -0500

ANAND gravatar image

I get the same error too on rhel 73 my host name is rhel-packstack1.rdo.home

is this enough ??

my resolv.conf has search vlan entry before the dns server entry

what should i specify for the below entries in answer-file ??

my interace name is eth0 ( renamed from enp0s3 ) and my vm is a virtualbox vm .

how do i know if shoulduyse physnet1 or extnet or eth0 ??

Comma-separated list of bridge mappings for the OpenStack

Networking Open vSwitch plugin. Each tuple in the list must be in

the format <physical_network>:<ovs_bridge>. Example: physnet1:br-

eth1,physnet2:br-eth2,physnet3:br-eth3

CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS=

Comma-separated list of colon-separated Open vSwitch

<bridge>:<interface> pairs. The interface will be added to the

associated bridge. If you desire the bridge to be persistent a value

must be added to this directive, also

CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS must be set in order to create

the proper port. This can be achieved from the command line by

issuing the following command: packstack --allinone --os-neutron-

ovs-bridge-mappings=ext-net:br-ex --os-neutron-ovs-bridge-interfaces

=br-ex:eth0

CONFIG_NEUTRON_OVS_BRIDGE_IFACES=

Comma-separated list of Open vSwitch bridges that must be created

and connected to interfaces in compute nodes when flat or vlan type

drivers are enabled. These bridges must exist in

CONFIG_NEUTRON_OVS_BRIDGE_MAPPINGS and

CONFIG_NEUTRON_OVS_BRIDGE_IFACES. Example: --os-neutron-ovs-bridges-

compute=br-vlan --os-neutron-ovs-bridge-mappings="extnet:br-

ex,physnet1:br-vlan" --os-neutron-ovs-bridge-interfaces="br-ex:eth1

,br-vlan:eth2"

CONFIG_NEUTRON_OVS_BRIDGES_COMPUTE=

Interface for the Open vSwitch tunnel. Packstack overrides the IP

address used for tunnels on this hypervisor to the IP found on the

specified interface (for example, eth1).

CONFIG_NEUTRON_OVS_TUNNEL_IF=

Appreciate your quick response in this regard

edit flag offensive delete link more
0

answered 2018-01-21 14:48:15 -0500

AaronK gravatar image

I'm brand new to installing openstack so I may not have it but I'm pretty sure you need to properly set an FQDN for the packstack installation.

hostnamectl set-hostname host.domain.com

Hopefully that will help,

Aaron

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2018-01-08 17:48:45 -0500

Seen: 168 times

Last updated: Jan 21