Ask Your Question
0

In controller node , there is not linuxbridge in the agent list

asked 2018-01-08 07:59:10 -0600

qykwok gravatar image

i have install the neutron in the controller node . but there is not linuxbridge in the agent , just only metadata && dhcp agent .

[root@openstack81 ~]# neutron agent-list +--------------------------------------+----------------+-------------+-------------------+-------+-------+------------------------+ | ID | Agent Type | Host | Availability Zone | Alive | State | Binary | +--------------------------------------+----------------+-------------+-------------------+-------+-------+------------------------+ | 14a8d503-3d06-4960-9374-df2fc70a1439 | Metadata agent | openstack81 | None | :-) | UP | neutron-metadata-agent | | d8c1ef30-4dbf-4a68-ba74-cefb2f441dfc | DHCP agent | openstack81 | nova | :-) | UP | neutron-dhcp-agent | +--------------------------------------+----------------+-------------+-------------------+-------+-------+------------------------+

in other hand .there is not any linuxbridge log in /var/log/neutron , [root@openstack81 neutron]# ll /var/log/neutron/ total 292 -rw-r--r-- 1 neutron neutron 41961 Jan 8 15:49 dhcp-agent.log -rw-r--r-- 1 neutron neutron 20353 Jan 8 15:49 metadata-agent.log -rw-r--r-- 1 neutron neutron 229378 Jan 8 15:53 server.log

[root@openstack81 neutron]# systemctl status neutron-linuxbridge-agent.service -l ● neutron-linuxbridge-agent.service - OpenStack Neutron Linux Bridge Agent Loaded: loaded (/usr/lib/systemd/system/neutron-linuxbridge-agent.service; enabled; vendor preset: disabled) Active: active (running) since Mon 2018-01-08 16:03:16 CST; 1s ago Process: 9046 ExecStartPre=/usr/bin/neutron-enable-bridge-firewall.sh (code=exited, status=0/SUCCESS) Main PID: 9053 (neutron-linuxbr) CGroup: /system.slice/neutron-linuxbridge-agent.service └─9053 /usr/bin/python2 /usr/bin/neutron-linuxbridge-agent --config-file /usr/share/neutron/neutron-dist.conf --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugins/ml2/linuxbridge_agent.ini --config-dir /etc/neutron/conf.d/common --config-dir /etc/neutron/conf.d/neutron-linuxbridge-agent --log-file /var/log/neutron/linuxbridge-agent.log

Jan 08 16:03:16 openstack81 systemd[1]: Starting OpenStack Neutron Linux Bridge Agent... Jan 08 16:03:16 openstack81 neutron-enable-bridge-firewall.sh[9046]: net.bridge.bridge-nf-call-iptables = 1 Jan 08 16:03:16 openstack81 neutron-enable-bridge-firewall.sh[9046]: net.bridge.bridge-nf-call-ip6tables = 1 Jan 08 16:03:16 openstack81 systemd[1]: Started OpenStack Neutron Linux Bridge Agent. Jan 08 16:03:17 openstack81 neutron-linuxbridge-agent[9053]: Guru meditation now registers SIGUSR1 and SIGUSR2 by default for backward compatibility. SIGUSR1 will no longer be registered in a future release, so please use SIGUSR2 to generate reports. [root@openstack81 neutron]#

[root@openstack81 ml2]# grep '^[a-Z]' linuxbridge_agent.ini
physical_interface_mappings = provider:eth0 firewall_driver = neutron.agent.linux.iptables_firewall.IptablesFirewallDriver enable_security_group = true enable_vxlan = false

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2018-01-11 01:35:24 -0600

Carrot gravatar image

May be you did not installing neutron-linuxbridge-agent or configure 'mechanism_drivers = linuxbridge ' in ml2_config.ini and dhcp_agent.ini and l3_agent.ini.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2018-01-08 07:59:10 -0600

Seen: 124 times

Last updated: Jan 11