Ask Your Question

Openstack : image can't be private

asked 2017-12-31 20:12:18 -0600

Darth-OpenStack gravatar image

Hello to everyone,

I'm a newbie in OpenStack and i have a specific problem/question.I have created a project "myproject" and i have added a user on it "myuser" with a role "member".I also have downloaded the rc file of the project (v3 and v2) because i want to work with CLI.

First of all i want to refer that i have already install the devstack successfully , with 1 NIC , 1 compute node and it's working perfect(it can ping also internet addresses).Inside my devstack user "stack@vm:~devstack$" i typed "source",continued with the password of the user and i'm already inside my project...everything looks and works fine but the problem is that : i created an image either with glance commands either with openstack commands and i put the image as private(that means that is visible only in this current user)...BUT if i login with the admin's credentials i can see the image of my tenant user (myuser) and in the space of private is shows "Image from Other Project - Non-Public"....

Even from horizon, as the tenant user i can't edit the visibility of image(in the image sharing section) doesn't this because my user has a "member" role?

Thank you in advance !

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2018-01-01 01:51:46 -0600

The image is private. By default, only admin users can make images public. This behaviour is controlled by the publicize_image key in /etc/glance/policy.json.

edit flag offensive delete link more


Oh i see, this explains everything. Thank you!

Darth-OpenStack gravatar imageDarth-OpenStack ( 2018-01-01 07:03:22 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools


Asked: 2017-12-31 20:12:18 -0600

Seen: 689 times

Last updated: Jan 01 '18