Ask Your Question
0

ssh into vm is slow but only for some vm's on openstack

asked 2017-12-26 09:25:26 -0500

jcorkey gravatar image

I used kolla 5.0.0 to deploy openstack on one control node and one compute node both running Centos 7. Everything seems to work well but the ssh login just takes too long. It takes almost a whole minute to log me into a vm on openstack. People have suggested it could be related to DNS so I have tried things like changing the option UseDNS to equal "no" in /etc/ssh/sshd_config ON the vm's. I also tried setting GSSAPIAuthentication to "no" in /etc/ssh/sshd_config on the vm's and restarted the sshd but these suggestions did not help anything.

The thing that is confusing me is that one of my instance I created does not give me trouble when I ssh into it but all the rest do. All my current instance were launched from snapshots of other vm's on another openstack environment. All the snapshots have Centos 7.

So why is it that most of my vm's take almost a minute to ssh into but one of them works just fine and has no delay when I ssh into it? Could this still be related to DNS?

Any suggestions on why this could be happening?

edit retag flag offensive close merge delete

Comments

can you compare /etc/resolv.conf on the VM which is working fine and other VM's.

TijoV gravatar imageTijoV ( 2017-12-27 03:00:28 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-12-30 01:53:40 -0500

Am Ab gravatar image

You may need to test some more options. - Have you ever test that by running "ssh -vvv"? - You may use "ssh -4 user@ip" to see if can helps or not. - If the vm using systemd, you may try "systemctl restart systemd-logind" and check ssh connection again.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-12-26 09:25:26 -0500

Seen: 159 times

Last updated: Dec 30 '17