tempest.lib.exceptions.InvalidCredentials: Invalid Credentials

asked 2017-12-19 03:41:55 -0500

billsung gravatar image

Hi all,

I currently solving the manila tempest issues.

I have tried several config, all tests just keep returning the invalid credentials error. The closet solution that I thought is using dynamic credentials like:

[auth]
use_dynamic_credentials=True
admin_username=admin
admin_project_name=tempest
admin_domain_name=Default
admin_password=infortrend

But sadly this doesn't work. All errors are the in the same pattern like:

Captured traceback:
~~~~~~~~~~~~~~~~~~~
Traceback (most recent call last):
  File "tempest/test.py", line 172, in setUpClass
    six.reraise(etype, value, trace)
  File "tempest/test.py", line 157, in setUpClass
    cls.setup_credentials()
  File "tempest/test.py", line 371, in setup_credentials
    credential_type=credentials_type)
  File "tempest/test.py", line 658, in get_client_manager
    cred_provider = cls._get_credentials_provider()
  File "tempest/test.py", line 636, in _get_credentials_provider
    force_tenant_isolation=force_tenant_isolation)
  File "tempest/common/credentials_factory.py", line 141, in get_credentials_provider
    **get_dynamic_provider_params(identity_version))
  File "tempest/common/credentials_factory.py", line 73, in get_dynamic_provider_params
    fill_in=True, identity_version=identity_version)
  File "tempest/common/credentials_factory.py", line 254, in get_configured_admin_credentials
    identity_version=identity_version, **params)
  File "tempest/common/credentials_factory.py", line 298, in get_credentials
    **params)
  File "tempest/lib/auth.py", line 647, in get_credentials
    http_timeout=http_timeout, proxy_url=proxy_url)
  File "tempest/lib/auth.py", line 265, in __init__
    super(KeystoneAuthProvider, self).__init__(credentials, scope)
  File "tempest/lib/auth.py", line 93, in __init__
    raise exceptions.InvalidCredentials(message)
tempest.lib.exceptions.InvalidCredentials: Invalid Credentials
Details: Credentials are: {'tenant_id': None, 'project_id': None, 'project_domain_name': None, 'project_domain_id': None, 'project_name': None, 'username': None, 'user_domain_id': None, 'user_id': None, 'user_domain_name': None, 'domain_id': None, 'tenant_name': None, 'domain_name': None} Password is not defined.

Any help is much appreciated.

edit retag flag offensive close merge delete