Cinder: Cannot mount Volumes

asked 2014-01-29 08:08:35 -0600

kemra102 gravatar image

I have Cinder setup to use Gluster as a backend.

I can create and attach volumes to an an instance without error.

If I then format the raw volume with say ext4 that succeeds but then I cannot mount it:

[root@myserver ~]# mount /dev/disk/by-id/virtio-2334575c-962d-47f2-9 /mnt
mount: you must specify the filesystem type
[root@myserver ~]# mount -t ext4 /dev/disk/by-id/virtio-2334575c-962d-47f2-9 /mnt
mount: wrong fs type, bad option, bad superblock on /dev/vdb,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

If I create a partition on it first rather than formatting the volume directly I get the following error:

[root@myserver ~]# mkfs.ext4 /dev/vdc1
mke2fs 1.41.12 (17-May-2010)
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=0 blocks, Stripe width=0 blocks
3276800 inodes, 13107142 blocks
655357 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=4294967296
400 block groups
32768 blocks per group, 32768 fragments per group
8192 inodes per group
Superblock backups stored on blocks: 
        32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208, 
        4096000, 7962624, 11239424

Warning: could not read block 0: Attempt to read block from filesystem resulted in short read
Writing inode tables: done                            
ext2fs_mkdir: Attempt to read block from filesystem resulted in short read while creating root dir

The volumes are backed by Gluster using the Cinder GlusterFS driver. Curiously I have noticed that after the volumes have been assigned they change their ownership from root:root to 107:107. No UID or GID exists with these numbers on the controller, in the guest or on the Gluster server. Unsure if this is my issue but it does seem odd that assigning the volume to an instance would cause it's ownership to change to none-existent IDs.

edit retag flag offensive close merge delete

Comments

do you have tried to mount your mounted disc manually ? You need to check if you have permissions to write on your cinder-volume server. Maybe you need to set the volume owner: gluster volume set openstack storage.owner-uid <cinder-uid> gluster volume set openstack storage.owner-gid <cinder-gid>

foexle gravatar imagefoexle ( 2014-01-29 08:46:12 -0600 )edit

How do you mean "mounted manually"? The above was mounting the disk inside the instance manually, or at least attempting to do so. I have already thought of setting those options on the Gluster share, it does correctly set the owner of the directory, but the volumes are created as root:too 666 permissions and still change to 107:107 after being attached.

kemra102 gravatar imagekemra102 ( 2014-01-30 01:23:18 -0600 )edit