Ask Your Question
1

Failed to establish a new connection. when I list endpoint

asked 2017-12-05 05:51:24 -0500

liaodalin19903 gravatar image

I can not list endpoint by openstack endpoint list:

[root@controller yun]# source ~/admin-openrc 
[root@controller yun]# openstack endpoint list
Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
Unable to establish connection to http://controller:35357/v3/auth/tokens: HTTPConnectionPool(host='controller', port=35357): Max retries exceeded with url: /v3/auth/tokens (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x249ca90>: Failed to establish a new connection: [Errno 111] \xe6\x8b\x92\xe7\xbb\x9d\xe8\xbf\x9e\xe6\x8e\xa5',))
edit retag flag offensive close merge delete

Comments

If it is queens or rocky release I think the controller port should be 5000

esxzawq gravatar imageesxzawq ( 2019-01-20 10:39:46 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
2

answered 2017-12-05 06:06:23 -0500

Errno 111 stands for "connection refused" and means that you have access to the controller at port 35357, but no process is listening at the port. I would guess that Keystone is not running, or your web server is not correctly configured for Keystone. It depends on your deployment what to do next. For example, if you use systemd, you could check if the status of the Keystone service. If you use Apache, look at /etc/APACHE_DIRECTORY/sites-enabled. Also check web server log and Keystone log.

edit flag offensive delete link more

Comments

my httpd did not start.

liaodalin19903 gravatar imageliaodalin19903 ( 2017-12-05 07:35:56 -0500 )edit

for my case it was missing Listen 35357 at /etc/apache2/sites-available/keystone.conf and section for virtualhost.. Just copied from: https://docs.openstack.org/mitaka/install-guide-ubuntu/keystone-install.html (https://docs.openstack.org/mitaka/ins...) even it is mitaka... worked.

Mindaugas M. gravatar imageMindaugas M. ( 2019-06-08 22:48:15 -0500 )edit
-1

answered 2019-01-20 06:29:29 -0500

amer.hwitat gravatar image

I have the same message with Error (400) and it's on Openstack 13 ....

I want to say that it's because of ironic-conductor (Baremetal services) is not running maybe ... you need to restart it ... if you have it installed on OSP 13 allinone as it'sby default not installed ..

you have to clean the nodes manually or set it up atuomatically ..

Best

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-12-05 05:51:24 -0500

Seen: 935 times

Last updated: Jan 20