systemctl restart httpd failed, when I don't know why there is python/django related

asked 2017-12-05 05:34:33 -0500

liaodalin19903 gravatar image

I can not start my httpd in openstack controller.

[root@controller ~]# systemctl restart httpd.service
Job for httpd.service failed because the control process exited with error code. See "systemctl status httpd.service" and "journalctl -xe" for details.
[root@controller ~]# systemctl status httpd.service
● httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
  Drop-In: /usr/lib/systemd/system/httpd.service.d
           └─openstack-dashboard.conf
   Active: failed (Result: exit-code) since 二 2017-12-05 19:34:35 CST; 9s ago
     Docs: man:httpd(8)
           man:apachectl(8)
  Process: 19022 ExecStartPre=/usr/bin/python /usr/share/openstack-dashboard/manage.py collectstatic --noinput --clear (code=exited, status=1/FAILURE)
 Main PID: 3388 (code=exited, status=0/SUCCESS)

12月 05 19:34:35 controller python[19022]: from django.contrib.auth.backends import RemoteUserBackend
12月 05 19:34:35 controller python[19022]: File "/usr/lib/python2.7/site-packages/Django-1.11.2-py2.7.egg/django/contrib/auth/backends.py", line 6, in <module>
12月 05 19:34:35 controller python[19022]: UserModel = get_user_model()
12月 05 19:34:35 controller python[19022]: File "/usr/lib/python2.7/site-packages/Django-1.11.2-py2.7.egg/django/contrib/auth/__init__.py", line 198, in get_user_model
12月 05 19:34:35 controller python[19022]: "AUTH_USER_MODEL refers to model '%s' that has not been installed" % settings.AUTH_USER_MODEL
12月 05 19:34:35 controller python[19022]: django.core.exceptions.ImproperlyConfigured: AUTH_USER_MODEL refers to model 'openstack_auth.User' that has not been installed
12月 05 19:34:35 controller systemd[1]: httpd.service: control process exited, code=exited status=1
12月 05 19:34:35 controller systemd[1]: Failed to start The Apache HTTP Server.
12月 05 19:34:35 controller systemd[1]: Unit httpd.service entered failed state.
12月 05 19:34:35 controller systemd[1]: httpd.service failed.
Hint: Some lines were ellipsized, use -l to show in full.

And the detail I have post in stackoverflow: https://stackoverflow.com/questions/4...

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2017-12-26 07:26:26 -0500

I'm with the same problem in my centos.

Did you find solution for it?

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-12-05 05:34:33 -0500

Seen: 455 times

Last updated: Dec 05 '17