modify default settings of lbaas haproxy

asked 2017-12-04 19:59:46 -0500

slosh_liuxin gravatar image

updated 2017-12-04 20:02:16 -0500

My openstack version is kilo,then i found that i can't modify the default settings of lbaas haproxy with "timeout" parameter.Such as like this:

    defaults
        log global
        retries 3
        option redispatch
        timeout connect 5000
        timeout client 50000
        timeout server 50000

    I want to raise 5000 --- 50000 and 50000--->500000,but when i change the conf with current lbaas conf and restart neutron-lbaas.service,there is not changed!
    I do not found a working way to slove this problems.
    Can anyone help me?Thanks very much!

List item

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-01-26 10:56:45 -0500

johnsom gravatar image

Hello,

For Octavia you can modify these in the jinja template at: octavia/common/jinja/haproxy/templates/base.j2 and restart your workers.

For the old namespace haproxy driver, you should be able to modify the template: neutron_lbaas/drivers/haproxy/templates/haproxy_base.j2 and restart both the neutron svc process and the lbaasv2 agents.

Michael

edit flag offensive delete link more

Comments

According to my experience, modify the template (neutron_lbaas/drivers/haproxy/templates/haproxy_base.j2) doesn't work to me, it will be replaced by the default config after restarting lbaasv2 agent.

corey gravatar imagecorey ( 2020-05-07 20:11:33 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-12-04 19:59:46 -0500

Seen: 316 times

Last updated: Jan 26 '18