Ask Your Question
1

heat list always get ERROR: Authentication required [closed]

asked 2014-01-29 03:04:21 -0600

RiscYu gravatar image

updated 2014-01-29 20:11:22 -0600

larsks gravatar image

I had installed OpenStack(havana) with allinone RDO in CentOS 6.4 64bit.

I cannot use heat commands to do anything, but the glance commands is workable.

I Export the env variables in keystonerc_admin When I lunch the command, It shows the following message

#heat list   
ERROR: Authentication failed. Please try again with option --include-password or export HEAT_INCLUDE_PASSWORD=1

Authentication required

Then I export HEAT_INCLUDE_PASSWORD=1

and I lunch the command again

I get the following massage

#heat list   
ERROR: Authentication required

Is the root cause is the missing files:

  • /etc/heat/heat-engine.conf
  • /etc/heat/heat-api{,-cfn,-cloudwatch}-paste.ini

there is only the file heat.conf in /etc/heat/

Or there are something needed setting?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by RiscYu
close date 2014-02-04 19:57:19.784080

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-02-04 19:51:02 -0600

RiscYu gravatar image

updated 2014-02-06 17:39:18 -0600

smaffulli gravatar image

I had found the root cause in my lab. As I executed the command # tail -l /var/log/heat/heat-api-cfn.log I get the following message. unable to access signing_dir /tmp/keystone-signing-heat. I changed the directory's access mode from 700 to 755 and restart the service. Then the problem is solved.

edit flag offensive delete link more
1

answered 2014-01-29 08:41:47 -0600

foexle gravatar image

Hi,

check if you have added in your heat.conf

[keystone_authtoken]

auth_uri = https://xxx:5000/v2.0
auth_host = xxxx
auth_port = 35357
auth_protocol = https
admin_tenant_name = service
admin_user = <user>
admin_password = <pw>
auth_version = v2.0
insecure=true

you should check with heat --debug list

Cheers Heiko

edit flag offensive delete link more

Comments

1

I had tested is in my lab, the error message is still appeared. I don't know what's worng in my lab' environment. Is something worng in my install process or something I need to config?

RiscYu gravatar imageRiscYu ( 2014-02-04 18:43:40 -0600 )edit

I referenced http://openstack.redhat.com/Deploying_Heat_on_Havana And I executed #heat-manage db_sync #service openstack-heat-engine restart now I get a new message: Error communicating with http://10.144.190.195:8004/v1/7dd7c257c6e14374ad1aa26d4c1b8da6 [Errno 111] Connection refused

RiscYu gravatar imageRiscYu ( 2014-02-04 19:26:55 -0600 )edit

I can not access http://10.144.190.195:8004 on browser, it seems the situation is getting worse. I don't know what happen?

RiscYu gravatar imageRiscYu ( 2014-02-04 19:28:21 -0600 )edit

I have the same problem in Juno over Centos & I'm following the Openstack installation document ,I read all and I mean all the ( heat - -Authentication ) tags I couldn't found a solution yet. your help is appreciated.

Alwan gravatar imageAlwan ( 2015-06-22 19:42:18 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-01-29 03:04:21 -0600

Seen: 4,003 times

Last updated: Feb 06 '14