Swift stat, verification, Errno[111]

asked 2017-11-17 09:50:00 -0500

Arthured94 gravatar image

updated 2017-11-23 05:23:20 -0500

Hi everyone, I had a problem during the installation of swift. In the last part of the Object Storage installation:

link:[https://docs.openstack.org/mitaka/install-guide-ubuntu/swift-verify.html]

After I Source the demo credentials:

$ . demo-openrc

I run

root@ubuntuserver:~# swift stat
HTTPConnectionPool(host='controller' , port=8080): Max retries exceeded with url: /v1/AUTH_fdc295d9c93641e78efe0b3753cb18e2 (Caused by NewConnectionError(' <requests.packages.urlib3.connection.HTTPConnection object at 0x7ff2e98ad290>: Failed to estrablish a new connection: [Errno 111] Connection refused' ,))

I run

ss -lntp | grep 8080

But Nothing is listening... How can I solve this.. what I have to watch? Some configuration file? Swift proxy server looks fine... When I run on the controller

# service swift-proxy start

I receive no errors... No errors even when I run

# swift-init all start

On the object node...

Please can someone help me?

I'm running under Ubuntu 17.04 on Virtualbox 5.1.22, using Pike.

edit retag flag offensive close merge delete

Comments

1

The keystone client is long obsolete. I don't understand why you use it when you follow the Mitaka instructions. Use the openstack client instead.

openstack endpoint list
openstack endpoint create

By the way, Mitaka is also rather old. The current version is Pike.

Bernd Bausch gravatar imageBernd Bausch ( 2017-11-19 08:34:39 -0500 )edit
1

I doubt that your problem is lack of endpoint. The swift client says host controller, port 8080. I guess that you swift proxy server(s) are not running or not accessible due to network misconfiguration.

Bernd Bausch gravatar imageBernd Bausch ( 2017-11-19 08:36:29 -0500 )edit

I just updated all, now I'm on Pike. Can you help me to solve errno [111]?

Arthured94 gravatar imageArthured94 ( 2017-11-20 14:26:57 -0500 )edit

111 means that nothing listens on port 8080. Are the swift proxy servers running and listening on that port? Run

sudo ss -lntp | grep 8080

to find out.

Bernd Bausch gravatar imageBernd Bausch ( 2017-11-20 16:10:57 -0500 )edit

Nothing is listening... How can I solve this.. what I have to watch? Some configuration file? Swift proxy server looks fine... When I run on the controller

# service swift-proxy start

I receive no errors...

No errors even when I run

# swift-init all start

On the object node...

Arthured94 gravatar imageArthured94 ( 2017-11-22 10:47:35 -0500 )edit