Ask Your Question
0

Ocata > Pike: Service is older on server list

asked 2017-11-16 05:05:47 -0500

rarni gravatar image

Hi i am running Openstack on Ubuntu 16.04 with cloud-archive ppa enabled. After upgrading from ocata to pike i get the following error when try an "openstack server list"

This service is older (v15) than the minimum (v22) version of the rest of the deployment. Unable to continue. (HTTP 400) (Request-ID: req-b74ffd6b-0fad-40cc-8fe6-160760518869)

Any suggestions how I can track this error?


root@controller:~# dpkg-query -l |grep nova |cut -b 1-65
ii  nova-api                           2:16.0.1-0ubuntu1~cloud0  
ii  nova-common                        2:16.0.1-0ubuntu1~cloud0  
ii  nova-conductor                     2:16.0.1-0ubuntu1~cloud0  
ii  nova-consoleauth                   2:16.0.1-0ubuntu1~cloud0  
ii  nova-novncproxy                    2:16.0.1-0ubuntu1~cloud0  
ii  nova-placement-api                 2:16.0.1-0ubuntu1~cloud0  
ii  nova-scheduler                     2:16.0.1-0ubuntu1~cloud0  
ii  python-nova                        2:16.0.1-0ubuntu1~cloud0  
ii  python-novaclient                  2:9.1.0-0ubuntu1~cloud0
edit retag flag offensive close merge delete

Comments

after reinstalling the whole server, using directly pike repo and reimporting the database the error remains the same

rarni gravatar imagerarni ( 2017-11-20 01:36:30 -0500 )edit

did you upgraded your database to the latest version ?

timi gravatar imagetimi ( 2017-11-20 07:20:18 -0500 )edit

yes i did. and i think i have upgraded all (sorry i am new to openstack so there is big possibility i oversee some) when it comes to nova i did nova-manage db sync and nova-manage api_db sync

is there a way to check all the databases about the current version they have?

rarni gravatar imagerarni ( 2017-11-21 04:01:09 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-12-19 00:20:00 -0500

GMichaud gravatar image

Same problem here:

This service is older (v9) than the minimum (v22) version of the rest of the deployment. Unable to continue. (HTTP 400)

I will be very glad to have a solution for that.

Thank you.

SOLUTION:

I had non-used hosts in my "services" table ("nova" database) that had old versions. Deleting these entries solved my problem:

mysql -uroot -p

USE nova;

DELETE FROM services WHERE version = '9';

edit flag offensive delete link more

Comments

Hello GMichaud, what documentation did you follow to update Ocata? Thank you in advance.

Marcio Prado gravatar imageMarcio Prado ( 2018-04-10 17:05:05 -0500 )edit

The trick helped. We also experienced this when we upgraded to Rocky. From openstack compute services list, you won't see any version issue. Have to look into db table 'nova.services'.

cshen gravatar imagecshen ( 2019-06-18 08:27:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-11-16 05:05:47 -0500

Seen: 554 times

Last updated: Dec 19 '17