Ask Your Question

kolla-build Error installing fluent-plugin-rewrite-tag-filter serverengine requires Ruby version >= 2.1.0

asked 2017-11-14 10:20:52 -0600

jcorkey gravatar image

I am using kolla/kolla-ansible 5.0.0 and I just built all the container images and pushed them to my local docker registry. There is one image that kolla fails to build which is the fluentd image. Below is my error I get in the fluentd.log: 7/8 : RUN ulimit -n 65536     && gem install --minimal-deps activesupport:4.2.9
 public_suffix:2.0.5 fluent-plugin-parser fluent-plugin-kubernetes_metadata_filter fluent-plugin-elasticsearch flue
nt-plugin-grep fluent-plugin-grok-parser:0.3.1 fluent-plugin-rewrite-tag-filter     && chmod -R 440 /etc/sudoers.d/
kolla_fluentd_sudoers      && chmod 755 /usr/local/bin/kolla_extend_start     && mkdir -p /var/run/fluentd     && c
hown -R fluentd: /etc/fluentd /var/run/fluentd ---> Running in 58b04375bfb9 to convert "\x84" from ASCII-8BIT to UTF-8 for lib/active_support/values/
unicode_tables.dat, skipping installed concurrent-ruby-1.0.5 installed i18n-0.9.1 installed minitest-5.10.3 installed activesupport-4.2.9 documentation for concurrent-ruby-1.0.5 ri documentation for concurrent-ruby-1.0.5 documentation for i18n-0.9.1 ri documentation for i18n-0.9.1 documentation for minitest-5.10.3 ri documentation for minitest-5.10.3 documentation for activesupport-4.2.9 ri documentation for activesupport-4.2.9 installed public_suffix-2.0.5 documentation for public_suffix-2.0.5 ri documentation for public_suffix-2.0.5 installed fluent-plugin-parser-0.6.1 documentation for fluent-plugin-parser-0.6.1 ri documentation for fluent-plugin-parser-0.6.1 installed lru_redux-1.1.0 native extensions.  This could take a while...  Error installing fluent-plugin-elasticsearch: serverengine requires Ruby version >= 2.1.0.  Error installing fluent-plugin-rewrite-tag-filter: serverengine requires Ruby version >= 2.1.0.

You can see at the bottom that it is complaining about not being able to install fluent-plugin-elasticsearch and fluent-plugin-rewrite-tag-filter. It says serverengine requires Ruby version >= 2.1.0. How can I get it to have ruby 2.1 and will that fix it?? I really need this container to build.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2017-11-14 10:49:36 -0600

jcorkey gravatar image

i. Vi /usr/share/kolla/docker/fluentd/DockerFile.j2 1. Find where it says RUN ulimit -n 65536 ** and replace the second line that starts with **&& gem install with the following text:

&& gem install --minimal-deps activesupport:4.2.9 public_suffix:2.0.5 fluent-plugin-parser fluent-plugin-kubernetes_metadata_filter fluent-plugin-elasticsearch:1.10.2 fluent-plugin-grep fluent-plugin-grok-parser:0.3.1 fluent-plugin-rewrite-tag-filter:1.6.0 fluent-plugin-secure-forward \
edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2017-11-14 10:20:52 -0600

Seen: 753 times

Last updated: Nov 14 '17