packstack installation fails with mysql access denied error

asked 2014-01-28 11:32:49 -0600

sivasamyk gravatar image

While installing packstack in CentOS 6.4 I am getting following error :

2014-01-28 13:40:05.135 9318 CRITICAL keystone [-] (OperationalError) (1045, "Access denied for user 'keystone_admin'@'CENT-LINUX-DT' (using password: YES)") None None

Command used to install packstack :

packstack --allinone

I tried deleting the mysql installation (as mentioned in http://openstack.redhat.com/forum/discussion/238/resolved-install-error-with-nagios/p1 ), clearing /var/lib/mysql and reinstalling mysql, with no effect.

If I try to login into mysql using " mysql -u keystone_admin -p" with password as mentioned in /etc/keystone.conf file login is sucessful. If I use "mysql -u keystone_admin -h IP_ADDRESS -p" login fails.

Let me know how I can resolve this issue or if more informatoin/logs is required.

edit retag flag offensive close merge delete

Comments

Is this an all-in-one or multi-node install? It *looks* like an issue with the MySQL database grants for remote connections or connections using the hostname/public ip (those not routed via 127.0.0.1).

sgordon gravatar imagesgordon ( 2014-01-28 12:36:35 -0600 )edit

Is selinux disabled? How does your /etc/hosts and /etc/sysconfig/network looks like? Did you use the hammer-uninstall script and rebooted your machine?

cloudssky gravatar imagecloudssky ( 2014-01-29 13:22:35 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-01-28 16:01:40 -0600

cloudssky gravatar image

Use this script to uninstall your packstack allinone and reboot your machine: https://github.com/marafa/openstack/blob/master/openstack-hammer-uninstall.sh and run poackstack again, it worked always for me.

edit flag offensive delete link more

Comments

It worked for me, too, now :)

Arne Wiebalck gravatar imageArne Wiebalck ( 2014-03-14 10:43:57 -0600 )edit
0

answered 2014-01-29 12:18:19 -0600

sivasamyk gravatar image

updated 2014-01-29 12:18:30 -0600

@sgordon it is all-in-one installation @cloudssky I have already tried packstack uninstallation but to no avail. For now I have started packstack without all-in-one and mysql with 127.0.0.1 as IP address. It seems to work fine so far.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-01-28 11:32:49 -0600

Seen: 3,074 times

Last updated: Jan 28 '14