Ask Your Question
0

after insalling devstack http://server-ip:5000 not accessible

asked 2017-10-30 13:51:14 -0500

sipian gravatar image

I followed https://www.theurbanpenguin.com/installing-devstack-on-ubuntu-16-04/ tutorial to install devstack(queens release) on my Ubuntu 16.04 server.

After the installation was done I ran the following commands

export OS_USERNAME=admin
export OS_TENANT_NAME=admin
export OS_PASSWORD=<password>
export OS_AUTH_URL=http://server-ip:5000/v2.0
openstack image create --public --disk-format qcow2 --container-format bare --file /home/cse3/ubuntu_images/ubuntu-14.04-server-cloudimg-amd64-disk1.img ubuntu

But whenever I open http://server-ip:5000/v2.0 in my browser I am getting unable to connect error. When I create an image from the command line I get the following message

Failed to discover available identity versions when contacting http://server-ip:5000/v2.0. Attempting to parse version from URL. Unable to establish connection to http://server-ip:5000/v2.0/tokens: HTTPConnectionPool(host='server-ip', port=5000): Max retries exceeded with url: /v2.0/tokens (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f84ebecabd0>: Failed to establish a new connection: [Errno 111] Connection refused',))

Can anyone suggest what steps need to be followed to remove this error?

edit retag flag offensive close merge delete

Comments

There has been a push to remove port numbers from URLs. DevStack Queens deploys most services behind Apache, including Keystone at http://server/identity instead of http://server:5000.

See also https://governance.openstack.org/tc/g....

Bernd Bausch gravatar imageBernd Bausch ( 2017-11-02 04:56:37 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2018-02-21 07:35:31 -0500

It seems that i've found the solution - your just need to switch devstack branch to stable/newton and add several lines in local.config:

HORIZON_BRANCH=newton-eol

and the same for NOVA, KEYSTONE, CINDER, GLANCE, NEUTRON, etc...

newton-eol is a git tag, since there is no newton branch in several projects...

edit flag offensive delete link more

Comments

That’s a solution if you are happy with a version of OpenStack that has reached EOL, and if you recreate your cloud from scratch. To work with Queens (also Pike if I remember well), the OP’s authentication URL needs to be replaced by http://server-ip/identity.

Bernd Bausch gravatar imageBernd Bausch ( 2018-02-22 21:03:19 -0500 )edit

Agreed but how do we fix this error. Still see the issue and have tried all the workaround apart from the one to use Newton. Want this to be up and running with Ubuntu 16.04 and queens but no luck.

agupta gravatar imageagupta ( 2018-09-19 13:29:34 -0500 )edit

By default, Queens devstack does not deploy Keystone API v2. Therefore, use http://server-ip/identity as AUTH_URL The openrc script in ~/devstack does that.

Of course, you could have a different problem than the one discussed here.

Bernd Bausch gravatar imageBernd Bausch ( 2018-09-19 16:54:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2017-10-30 13:51:14 -0500

Seen: 249 times

Last updated: Oct 30 '17