horizon error

asked 2014-01-28 11:00:42 -0500

ygk gravatar image

Hi All,

I have installed openstack on two nodes. Compute and controller node. Networking also is installed on the controller node. I am able to create an instance from backend using nova boot command from command line. But if I try to launch the instance from dashboard, a line starts revolving at the centre of the screen and it goes on for a long time. In the end two error messages are displayed on the screen. One is "unable to launch the instance" and the other is "the server has either erred or is incapable ...................................." .

In the nova-api logs, rpc timeouts for network are observed ? What is causing the error in the dashbaord ?

edit retag flag offensive close merge delete

Comments

Can you check apache logs or syslogs ? It must have some error

dheeru gravatar imagedheeru ( 2014-01-28 11:12:21 -0500 )edit

If a restart of keystone and httpd doesn't help, then try to reboot both servers and if it doesn't still help, I guess you've to give your setup a new chance or resinstall Horizon. Which install pack and which OS are you using?

cloudssky gravatar imagecloudssky ( 2014-01-28 16:29:52 -0500 )edit

apache logs also show the same error message 'the server has either erred or is incapable ...................................'.

ygk gravatar imageygk ( 2014-01-28 23:26:15 -0500 )edit

let us look at this together sometime time in the evening and fix your issue.

dheeru gravatar imagedheeru ( 2014-01-30 00:50:20 -0500 )edit

Can you add the traceback from the apache logs to the question?

jpichon gravatar imagejpichon ( 2014-01-31 05:55:07 -0500 )edit