Error executing: "ceilometer meter-list"

asked 2017-10-25 09:37:55 -0500

michelgokan3 gravatar image

updated 2017-10-26 07:49:29 -0500

Hi,

When I execute openstack metric metric list I'm getting no error and get list of metrics available. But when I use ceilometer meter-list, I'm getting following error:

HTTPConnectionPool(host='172.16.16.110', port=8777): Max retries exceeded with url: /v2/meters (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x7fbf40a5c610>: Failed to establish a new connection: [Errno 111] Connection refused',))

My ceilometer.conf in controller:

[DEFAULT]
metering_api_port = 8777
auth_strategy = keystone
log_dir = /var/log/ceilometer
host = 172.16.16.110
pipeline_cfg_file = pipeline.yaml
hypervisor_inspector = libvirt
nova_control_exchange = nova
glance_control_exchange = glance
neutron_control_exchange = neutron
cinder_control_exchange = cinder
libvirt_type = qemu
debug = false
notification_topics = notifications
transport_url = rabbit://openstack:somepass@172.16.16.110:5672//openstack
heat_control_exchange = heat
control_exchange = ceilometer
http_control_exchanges = nova
http_control_exchanges = glance
http_control_exchanges = cinder
http_control_exchanges = neutron


http_control_exchanges = glance
http_control_exchanges = cinder
http_control_exchanges = neutron
instance_name_template = instance-%08x
dispatcher = gnocchi
meter_dispatchers = gnocchi
event_dispatchers = gnocchi

[api]
port = 8777
host = 172.16.16.110

[collector]
workers = 2

[compute]

[coordination]

[cors]

[cors.subdomain]

[database]
metering_time_to_live = 604800
time_to_live = 604800
event_time_to_live = 604800

[dispatcher_file]

[dispatcher_gnocchi]
filter_service_activity = False
archive_policy = low
[dispatcher_http]

[event]

[hardware]

[ipmi]

[keystone_authtoken]
auth_host = 172.16.16.110
auth_port = 35357
admin_tenant_name = services
admin_user = ceilometer
admin_password = somepass
auth_type = password
username = ceilometer
password = somepass
project_domain_name = default
user_domain_name = default
project_name = services
auth_uri = http://172.16.16.110:5000
auth_url = http://172.16.16.110:35357
signing_dir = /var/lib/ceilometer/tmp-signing
auth_version = v3
memcached_servers = 172.16.16.110:11211


[matchmaker_redis]

[meter]

[notification]
workers = 2
messaging_urls = rabbit://openstack:somepass@172.16.16.110:5672//openstack

[oslo_concurrency]

[oslo_messaging_amqp]

[oslo_messaging_kafka]

[oslo_messaging_notifications]
topics = notifications
driver = messagingv2

[oslo_messaging_rabbit]

[oslo_messaging_zmq]

[oslo_middleware]

[oslo_policy]

[polling]

[publisher]
telemetry_secret = fe01a6ed3e04c4be1cd8

[publisher_notifier]
telemetry_driver = messagingv2
metering_topic = metering
event_topic = event

[rgw_admin_credentials]

[service_credentials]
os_username = ceilometer
os_password = somepass
os_tenant_name = services
os_auth_url = http://172.16.16.110:5000/v3
os_region_name = CarlLab
os_endpoint_type = internalURL
region_name = CarlLab
interface = internal
auth_type = password
username = ceilometer
password = somepass
auth_url = http://172.16.16.110:5000/v3
project_domain_name = default
user_domain_name = default
project_name = services

[service_types]
neutron = network
nova = compute
swift = object-store
glance = image
neutron_lbaas_version = v2

[storage]

[vmware]

[xenapi]

[alarm]
evaluation_service = ceilometer.alarm.service.SingletonAlarmService
partition_rpc_topic = alarm_partition_coordination


[exchange_control]
heat_control_exchange = heat
glance_control_exchange = glance
keystone_control_exchange = keystone
cinder_control_exchange = cinder
sahara_control_exchange = sahara
swift_control_exchange = swift
magnum_control_exchange = magnum
trove_control_exchange = trove
nova_control_exchange = nova
neutron_control_exchange = neutron

And here is my gnocchi status results:

[root@controller ~(keystone_fulladmin)]$ gnocchi status
+-----------------------------------------------------+--------+
| Field                                               | Value  |
+-----------------------------------------------------+--------+
| storage/number of metric having measures to process | 135    |
| storage/total number of measures to process         | 161297 |
+-----------------------------------------------------+--------+

The " storage/total number of measures to process" is ridiciously high and I don't know what is the problem all over here...because then I get empty measures:

$ openstack metric measures show memory.usage --resource-id 93d66803-88dc-4ad8-90a6-a9ff9ce2ff90


$

Any idea how to fix this?

edit retag flag offensive close merge delete

Comments

Hi, is that a typo at transport_url and messaging_urls with double slash // at the end??

Praveen N gravatar imagePraveen N ( 2017-10-26 02:39:21 -0500 )edit

@praveenN Well, it seems yes, according to the automated installer.

michelgokan3 gravatar imagemichelgokan3 ( 2017-10-26 02:53:50 -0500 )edit

is this pike/ocata? use openstack metric ... instead of ceilometer command

timi gravatar imagetimi ( 2017-11-10 16:00:35 -0500 )edit