Get Error when Create A Zone

asked 2017-10-25 07:06:20 -0500

DanielXu gravatar image

updated 2017-10-25 12:35:35 -0500

Hi, I am trying to deploy designate service in Ocata follwoing ( I am using a external DNS setup on another Server. When create a new zone , the status keeps pending and evan when I delete this zone, the action changes to delete and status also keeps pending. Shall I add following to /etc/neutron/neutron.conf

external_dns_driver = designate 
url = http://controller:9001/v2
admin_auth_url = http://controller:35357/v2.0
admin_username = neutron
admin_password = r00tme
admin_tenant_name = service
allow_reverse_dns_lookup = True
ipv4_ptr_zone_prefix_size = 24
ipv6_ptr_zone_prefix_size = 116

# cat /etc/designate/pools.yaml
    - name: default
      # The name is immutable. There will be no option to change the name after
      # creation and the only way will to change it will be to delete it
      # (and all zones associated with it) and recreate it.
      description: Default Pool

      attributes: {}

      # List out the NS records for zones hosted within this pool
      # This should be a record that is created outside of designate, that
      # points to the public IP of the controller node.
        - hostname: dns1.esgyncn.local.
          priority: 1

  # List out the nameservers for this pool. These are the actual BIND servers.
  # We use these to verify changes have propagated to all nameservers.
    - host:
      port: 53

  # List out the targets for this pool. For BIND there will be one
  # entry for each BIND server, as we have to run rndc command on each server
    - type: bind9
      description: BIND9 Server 1

      # List out the designate-mdns servers from which BIND servers should
      # request zone transfers (AXFRs) from.
      # This should be the IP of the controller node.
      # If you have multiple controllers you can add multiple masters
      # by running designate-mdns on them, and adding them here.
        - host:
          port: 5354

      # BIND Configuration options
        port: 53
        rndc_port: 953
        rndc_key_file: /etc/designate/rndc.key

errors in /var/log/designate/worker.log

2017-10-26 01:28:13.785 20256 INFO [-] Failed to CREATE zone example.local. on target 045692e9-30bd-445f-ab4e-9e3d607e23f0 on attempt 9, Error: Unexpected error while running command.
Command: sudo designate-rootwrap /etc/designate/rootwrap.conf rndc -s -p 953 -k /etc/designate/rndc.key addzone example.local  { type slave; masters { port 5354;}; file "slave.example.local.9062c789-aa4b-4d65-88e8-c015634347c4"; };
Exit code: 96
Stdout: u''
Stderr: u'/usr/bin/designate-rootwrap: Executable not found: /usr/sbin/rndc (filter match = rndc)\n'.
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2017-10-25 23:24:46 -0500

martbhell b gravatar image

Executable not found: /usr/sbin/rndc

Does installing rndc from bind help?

edit flag offensive delete link more


bind in not installed on my designate node. But i am still not understand. For example. is my dns server in my company. is designate node. Is it possible to make designate node( work as a slave and dns server work( work as master? Thank you so much

DanielXu gravatar imageDanielXu ( 2017-10-26 10:36:54 -0500 )edit

You need to install rndc on the designate node (wherever designate-worker is running) to allow designate control the bind server.

grahamhayes gravatar imagegrahamhayes ( 2018-03-07 12:31:43 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2017-10-25 07:06:20 -0500

Seen: 934 times

Last updated: Oct 25 '17