connection to neutron failed maximum attempts reached

asked 2014-01-28 08:26:47 -0500

Veena gravatar image

updated 2014-01-30 08:36:14 -0500

Running any neutron APIs gives the error as "connection to neutron failed maximum attempts reached". The logs /var/log/neutron/server.log.1 shows "AMQP server on localhost:5672 is unreachable: Socket closed. Trying again in 30 seconds." However rabbitmq is running on listening on port 5672. Nova can connect to rabbitmq. /var/log/nova/nova-conductor.log shows "[req-2c07b0a4-fc4a-4f64-8fb8-ffd99a1930e7 None None] Connected to AMQP server on controller:5672". I checked all the .conf files of neutron and nova, the configuration is done correctly as per the guide and the credentials are also set correct. I see in that the person reinstall the whole thing and gets it working. But I can't reinstall since I'm running out of time. I don't understand the problem with "neutron". Please somebody through light on this and help me to get rid of this error.

Thanks in advance...

edit retag flag offensive close merge delete



Is neutron and AMQP on the same box ? Please do let me know if you still have the same problem.

dheeru gravatar imagedheeru ( 2014-01-28 22:55:05 -0500 )edit

Hi, yes, neutron and AMQP are on the same server. I still have the problem with neutron.

Veena gravatar imageVeena ( 2014-01-29 03:12:47 -0500 )edit

Looks like some configuration issue you are hitting. Can you check your neutron configuration ? Please check whether configurations are in appropriate sections. e.g [DEFAULT ] [KEYSTONE] etc. You can check following sample configuration

dheeru gravatar imagedheeru ( 2014-01-29 03:33:43 -0500 )edit

Checked the config file with the reference that you had provided. Everything looks correct as per my settings and I had to comment out the rabbitmq_userid. But that did not help.

Veena gravatar imageVeena ( 2014-01-29 04:15:38 -0500 )edit

Now i feel you have the user name and password issue for rabbitmq. If it is ok for you, can you chat on google. I can help live to close this issue.

dheeru gravatar imagedheeru ( 2014-01-29 07:43:16 -0500 )edit