Ask Your Question
0

utf-8 codec error in openstack server --user-data

asked 2017-10-20 02:19:19 -0600

Venkatesh6114 gravatar image

I need to pass encrypted file( not a 'utf-8' coded string) for the --user-data property in openstack server.

I am getting error as "utf-8 codec can't decode byte 0x80 in position 32: invalid start byte"

Is there any way to pass the encrypted file to openstack server instance ?

edit retag flag offensive close merge delete

Comments

I suppose this is because python read it as unicode(string,'utf-8') . But don't know where to fix this.

Venkatesh6114 gravatar imageVenkatesh6114 ( 2017-10-20 02:21:43 -0600 )edit
1

cloud-init accepts several file formats, but I see nothing about encrypted files http://cloudinit.readthedocs.io/en/la.... If you only want to inject a file without processing by cloud-init, use the --file option.

Bernd Bausch gravatar imageBernd Bausch ( 2017-10-22 18:26:59 -0600 )edit

It really works well. Thanks !!

Venkatesh6114 gravatar imageVenkatesh6114 ( 2017-10-30 04:57:12 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-10-30 05:00:13 -0600

Venkatesh6114 gravatar image

As Bernd mentioned, we can feed encrypted file thru --file option.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-10-20 02:19:19 -0600

Seen: 20 times

Last updated: Oct 30 '17