Ceilometer not working on Ocata

asked 2017-10-19 14:53:30 -0500

acassimiro gravatar image

updated 2017-12-13 17:58:44 -0500

I'm trying to learn how to deploy instances able to auto scale using the ceilometer and aodh plugins for monitoring and alarming on DevStack Ocata, following the instructions presented on https://docs.openstack.org/tacker/ocata/devref/alarm_monitoring_usage_guide.html (this link). After a few tests using the Ubuntu Server 16.04 as the VDU OS with a stress tool to constantly use 100% of the CPU capacity, I've noticed that the scaling operation would not be triggered and the alarm state would always show "insufficient data".

After this, I've done a few modifications to the TOSCA file displayed on the tutorial trying to simplify the situation and get a better understanding of what is going on.

This is was the resulting code, which also still does not work:

tosca_definitions_version: tosca_simple_profile_for_nfv_1_0_0
description: Demo example

metadata:
 template_name: sample-tosca-vnfd

topology_template:
  node_templates:
    VDU1:
      type: tosca.nodes.nfv.VDU.Tacker
      capabilities:
        nfv_compute:
          properties:
            disk_size: 10 GB
            mem_size: 2048 MB
            num_cpus: 1
      properties:
        image: ubuntu-server-16.04
        mgmt_driver: noop
        availability_zone: nova
        metadata: {metering.vnf: SG1}

    CP1:
      type: tosca.nodes.nfv.CP.Tacker
      properties:
        management: true
        anti_spoofing_protection: false
      requirements:
        - virtualLink:
            node: VL1
        - virtualBinding:
            node: VDU1

    VL1:
      type: tosca.nodes.nfv.VL
      properties:
        network_name: net_mgmt
        vendor: Tacker

  policies:
    - SP1:
        type: tosca.policies.tacker.Scaling
        properties:
          targets: [VDU1]  
          increment: 1
          cooldown: 30
          min_instances: 1
          max_instances: 3
          default_instances: 1

    - vdu1_cpu_usage_monitoring_policy:
        type: tosca.policies.tacker.Alarming
        triggers:
            resize_compute:
                event_type:
                    type: tosca.events.resource.utilization
                    implementation: ceilometer
                metrics: cpu_util
                condition:
                    threshold: 70
                    constraint: utilization greater_than 70%
                    period: 120
                    evaluations: 1
                    method: avg
                    comparison_operator: gt
                metadata: SG1  
                actions: [SP1]

And this is my local.conf file:

[[local|localrc]]
ADMIN_PASSWORD=secret
DATABASE_PASSWORD=$ADMIN_PASSWORD
RABBIT_PASSWORD=$ADMIN_PASSWORD
SERVICE_PASSWORD=$ADMIN_PASSWORD

CEILOMETER_PIPELINE_INTERVAL=10

enable_plugin heat https://git.openstack.org/openstack/heat stable/ocata
enable_plugin tacker https://git.openstack.org/openstack/tacker stable/ocata
enable_plugin ceilometer https://git.openstack.org/openstack/ceilometer stable/ocata
enable_plugin aodh https://git.openstack.org/openstack/aodh stable/ocata

I'm still researching about the Ceilometer and Aodh plugins at the moment, but I don't know what should be done in order to get this to work. Can anyone shed a light on how can I proceed here?

edit retag flag offensive close merge delete

Comments

According to https://git.openstack.org/cgit/openst..., the default Ceilometer backend is none. I am not sure about the consequences; could it be that samples are not stored? Try setting it to mongodb or mysql.

Also check the aodh logs.

Bernd Bausch gravatar imageBernd Bausch ( 2017-12-13 18:17:53 -0500 )edit