Senlin - HttpException: The request you have made requires authentication.

asked 2017-10-05 04:04:00 -0600

In devstack installed senlin, here my local.conf file below

> [[local|localrc]]


#Enable heat services
enable_service h-eng h-api h-api-cfn h-api-cw

#Enable heat plugin
enable_plugin heat

enable_plugin ceilometer

#to enable OSprofiler

enable_plugin aodh

#Enable senlin
enable_plugin senlin

# Disable tempest
disable_service tempest
# Disable sahara
disable_service sahara
# Disable trove
disable_service trove
disable_service tr-api
disable_service tr-mgr
disable_service tr-cond
# Disable swift
disable_service s-proxy
disable_service s-object
disable_service s-container
disable_service s-account

after installation tried to do autoscaling as per

while creating profile as per

> openstack cluster profile create --spec-file sample_server.yaml pserver

getting error as

openstack cluster profile create --verbose --spec-file sample_server.yaml pserver
START with options: [u'cluster', u'profile', u'create', u'--verbose', u'--spec-file', u'sample_server.yaml', u'pserver']
command: cluster profile create -> senlinclient.v1.profile.CreateProfile (auth=True)
Using auth plugin: password
HttpException: The request you have made requires authentication. (HTTP 401) (Request-ID: req-3a2990a1-0d8d-41e6-8a9a-1ab76d9f7aaa), The request you have made requires authentication.
END return value: 1

Here is my /etc/senlin/senlin.conf auto-created with devstack

transport_url = rabbit://stackrabbit:admin@
logging_exception_prefix = %(color)s%(asctime)s.%(msecs)03d TRACE %(name)s ^[[01;35m%(instance)s^[[00m
logging_debug_format_suffix = ^[[00;33mfrom (pid=%(process)d) %(funcName)s %(pathname)s:%(lineno)d^[[00m
logging_default_format_string = %(asctime)s.%(msecs)03d %(color)s%(levelname)s %(name)s [^[[00;36m-%(color)s] ^[[01;35m%(instance)s%(color)s%(message)s^[[00m
logging_context_format_string = %(asctime)s.%(msecs)03d %(color)s%(levelname)s %(name)s [^[[01;36m%(request_id)s ^[[00;36m%(project_name)s %(user_name)s%(color)s] ^[[01;35m%(instance)s%(color)s%(message)s^[[00m
use_syslog = False
default_region_name = RegionOne
auth_encryption_key = b6c693b6a3f96af85c58974ede813dad
debug = True

bind_port = 8778

connection = mysql+pymysql://root:admin@

admin_tenant_name = service
admin_password = admin
admin_user = senlin
auth_uri =
signing_dir = /var/cache/senlin
cafile = /opt/stack/data/ca-bundle.pem
identity_uri =

service_project_name = service
service_password = admin
service_username = senlin
auth_url =

project_domain_name = Default
user_domain_name = Default
auth_url =
project_name = service
password = admin
username = zaqar
auth_type = password

May I know why it was happening.. I can able to access all services except senlin .. how to resolve ?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2019-03-25 00:11:39 -0600

Anirudh gravatar image

updated 2019-03-25 00:12:27 -0600

Additionally, we need to give permissions in /etc/senlin/senlin.conf file


auth_url = http://controller:5000

auth_type = password

user_domain_name = default

username = senlin

password = <password>

After adding and restarting senlin engine and senlin api, this issue will get resolve

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2017-10-05 04:04:00 -0600

Seen: 1,820 times

Last updated: Mar 25 '19