ovs connection to local OF controller failed when having two flat provider networks

asked 2017-10-02 12:59:09 -0600

Planck-C gravatar image

Setup: Newton. /etc/neutron/plougins/ml2/openvswitch_agent.ini is configure with: bridge_mappings = external:br-ex, publicnet:br-ex-pub so two flat provider networks.

Symptoms: 1) ovs-ofctl dump-flows <br-ex br-ex-pub=""> shows flows are missing.Sometimes restarting the agent will get different results. 2) upon reviewing ovs-vswitchd.log : 2017-10-02T17:55:20.319Z|01335|rconn|INFO|br-ex<->tcp: connecting... 2017-10-02T17:55:20.320Z|01336|rconn|INFO|br-ex<->tcp: connected 2017-10-02T17:55:20.321Z|01337|rconn|INFO|br-ex-pub<->tcp: connection closed by peer 2017-10-02T17:55:28.321Z|01338|rconn|INFO|br-ex-pub<->tcp: connected 2017-10-02T17:55:28.322Z|01339|rconn|INFO|br-ex<->tcp: connection closed by peer 2017-10-02T17:55:29.320Z|01340|rconn|INFO|br-ex<->tcp: connecting... 2017-10-02T17:55:29.321Z|01341|rconn|INFO|br-ex<->tcp: connected 2017-10-02T17:55:29.321Z|01342|rconn|INFO|br-ex-pub<->tcp: connection closed by peer 3) if change configuration with only one bridge mapping to either br-ex or br-ex-pub. connections are steady. and flows are what I will expect.

Some observations: There were two bugs maybe related: https://lists.launchpad.net/yahoo-eng-team/msg60575.html (https://lists.launchpad.net/yahoo-eng...) https://bugzilla.redhat.com/show_bug.cgi?id=1425507 (https://bugzilla.redhat.com/show_bug....)

But no formal resolution yet.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2017-10-03 14:19:37 -0600

Planck-C gravatar image

This turned out to be an issue with Ryu (native mode) OF controller. When configured with multiple provider flat network, the controller seems rejecting connection from the two external br's.

So I switch the of_interface mode back to ovs-ofctl, the br connections works and flows are what I would expect.

edit flag offensive delete link more


Hi Planck-C, what do you mean by changing of_interface mode back to ovs-ofctl?

gianpietro gravatar imagegianpietro ( 2017-10-27 16:13:42 -0600 )edit

No worries, found the knob in the ovs section, thanks.

gianpietro gravatar imagegianpietro ( 2017-10-27 16:53:39 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2017-10-02 12:59:09 -0600

Seen: 824 times

Last updated: Oct 03 '17