Ask Your Question
2

ImportError: cannot import name UnrewindableBodyError

asked 2017-09-23 13:06:01 -0500

Abdallah Eldemerdash gravatar image

Hi All,

I tried to install openstack using pike and ocata versions but i am getting this error log when i setup using " packstack --allinone"

Notice: /Stage[main]/Neutron::Db::Sync/Exec[neutron-db-sync]/returns: ImportError: cannot import name UnrewindableBodyError Error: /Stage[main]/Neutron::Db::Sync/Exec[neutron-db-sync]: Failed to call refresh: neutron-db-manage upgrade heads returned 1 instead of one of [0] Error: /Stage[main]/Neutron::Db::Sync/Exec[neutron-db-sync]: neutron-db-manage upgrade heads returned 1 instead of one of [0] Notice: /Stage[main]/Neutron::Deps/Anchor[neutron::service::begin]: Triggered 'refresh' from 1 events Error: Failed to apply catalog: Execution of '/usr/bin/nova-manage cell_v2 list_cells --verbose' returned 1: Traceback (most recent call last): File "/usr/bin/nova-manage", line 6, in <module> from nova.cmd.manage import main File "/usr/lib/python2.7/site-packages/nova/cmd/manage.py", line 77, in <module> from nova.api.ec2 import ec2utils File "/usr/lib/python2.7/site-packages/nova/api/ec2/ec2utils.py", line 25, in <module> from nova import cache_utils File "/usr/lib/python2.7/site-packages/nova/cache_utils.py", line 22, in <module> import nova.conf File "/usr/lib/python2.7/site-packages/nova/conf/__init__.py", line 27, in <module> from nova.conf import cinder File "/usr/lib/python2.7/site-packages/nova/conf/cinder.py", line 16, in <module> from keystoneauth1 import loading as ks_loading File "/usr/lib/python2.7/site-packages/keystoneauth1/loading/__init__.py", line 13, in <module> from keystoneauth1.loading import adapter File "/usr/lib/python2.7/site-packages/keystoneauth1/loading/adapter.py", line 13, in <module> from keystoneauth1 import adapter File "/usr/lib/python2.7/site-packages/keystoneauth1/adapter.py", line 18, in <module> from keystoneauth1 import session File "/usr/lib/python2.7/site-packages/keystoneauth1/session.py", line 26, in <module> import requests File "/usr/lib/python2.7/site-packages/requests/__init__.py", line 43, in <module> import urllib3 File "/usr/lib/python2.7/site-packages/urllib3/__init__.py", line 8, in <module> from .connectionpool import ( File "/usr/lib/python2.7/site-packages/urllib3/connectionpool.py", line 35, in <module> from .connection import ( File "/usr/lib/python2.7/site-packages/urllib3/connection.py", line 44, in <module> from .util.ssl_ import ( File "/usr/lib/python2.7/site-packages/urllib3/util/__init__.py", line 4, in <module> from .request import make_headers File "/usr/lib/python2.7/site-packages/urllib3/util/request.py", line 5, in <module> from ..exceptions import UnrewindableBodyError ImportError: cannot import name UnrewindableBodyError

Can anyone help? Thanks!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
4

answered 2017-09-25 14:48:25 -0500

Abdallah Eldemerdash gravatar image

updated 2017-09-25 14:49:25 -0500

I found this soultion on SOF website:

"I have had this issue a couple times in the past few months. I haven't seen a good solution for fedora systems posted, so here's yet another solution. I'm using RHEL7, and I discovered the following:

If you have urllib3 installed via pip, and requests installed via yum you will have issues, even if you have the correct packages installed. The same will apply if you have urllib3 installed via yum, and requests installed via pip. Here's what I did to fix the issue:

sudo pip uninstall requests

sudo pip uninstall urllib3

sudo yum remove python-urllib3

sudo yum remove python-requests

(confirm that all those libraries have been removed)

sudo yum install python-urllib3

sudo yum install python-requests

Just be aware that this will only work for systems that are running Fedora, Redhat, or CentOS."

edit flag offensive delete link more

Comments

Encountered this when trying to run virt-manager. This solution worked for me.

Ankhwatcher gravatar imageAnkhwatcher ( 2018-05-23 06:00:22 -0500 )edit

This problem happened to me after a supplier upgraded our managed VMs. Thanks for the above steps! It worked perfectly!

sacummins gravatar imagesacummins ( 2018-10-13 06:11:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-09-23 13:06:01 -0500

Seen: 13,052 times

Last updated: Sep 25 '17