Keystone must start up on Httpd service? (a document bug?)

asked 2017-09-22 03:37:28 -0500

zero gravatar image

updated 2017-09-22 03:39:08 -0500

Hello,

I am new to keystone, I follow the doc https://docs.openstack.org/keystone/l..., and start up the keystone by using "uwsgi --http 127.0.0.1:5000 --wsgi-file $(which keystone-wsgi-public)" command. and it seems started up.

But when I run command "openstack token issue", It thrown an exception on client side like below:

Unable to establish connection to http://127.0.0.1/identity/v3/auth/tokens: HTTPConnectionPool(host='127.0.0.1', port=80): Max retries exceeded with url: /identity/v3/auth/tokens (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x43e0150>: Failed to establish a new connection: [Errno 111] Connection refused',))

I checked the server side, it reports this:

2017-09-22 04:28:52.179 32345 DEBUG keystone.middleware.auth [req-80bbd8c2-e735-45f3-a959-8597707e2513 - - - - -] There is either no auth token in the request or the certificate issuer is not trusted. No auth context will be set. fill_context /opt/stack/keystone/keystone/middleware/auth.py:205
2017-09-22 04:28:52.179 32345 INFO keystone.common.wsgi [req-80bbd8c2-e735-45f3-a959-8597707e2513 - - - - -] GET http://127.0.0.1:5000/v3/

I wonder it is because of Httpd service? Then I stop the uwsgi command, and use httpd service to start up Keystone. The command can issue token as normal.

I got several questions here:

  1. what makes keystone must start on httpd service?
  2. Is there any way for debug (like insert pdb break point)?

anyone can help ? thank in advance.

edit retag flag offensive close merge delete