floating IP cannot be reached

asked 2017-09-13 12:58:12 -0600

Jianliang gravatar image

Hi All,

I have installed OpenStack on 4 VMs (CentOS 7), with hostnames as controller, network, compute1 and compute2. I have OpenStack installed without getting errors now. But after deployed some instances, I met an error saying that the floating IP (master node) ssh connection time out. I tried to ping the floating IP from one of nodes but failed to reach the IP. The "ip a" information for the four nodes are as follows.

controller: 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: enp0s3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000 link/ether 08:00:27:ba:d2:48 brd ff:ff:ff:ff:ff:ff inet 192.168.99.106/24 brd 192.168.99.255 scope global dynamic enp0s3 valid_lft 883sec preferred_lft 883sec inet6 fe80::a00:27ff:feba:d248/64 scope link valid_lft forever preferred_lft forever 3: enp0s8: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000 link/ether 08:00:27:d3:58:dd brd ff:ff:ff:ff:ff:ff inet 192.168.99.197/26 brd 192.168.99.255 scope global dynamic enp0s8 valid_lft 697sec preferred_lft 697sec inet6 fe80::a00:27ff:fed3:58dd/64 scope link valid_lft forever preferred_lft forever

network: 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00 inet 127.0.0.1/8 scope host lo valid_lft forever preferred_lft forever inet6 ::1/128 scope host valid_lft forever preferred_lft forever 2: enp0s3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000 link/ether 08:00:27:c2:71:87 brd ff:ff:ff:ff:ff:ff inet 192.168.99.112/24 brd 192.168.99.255 scope global dynamic enp0s3 valid_lft 942sec preferred_lft 942sec inet6 fe80::a00:27ff:fec2:7187/64 scope link valid_lft forever preferred_lft forever 3: enp0s8: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000 link/ether 08:00:27:05:09:15 brd ff:ff:ff:ff:ff:ff inet 192.168.99.198/26 brd 192.168.99.255 scope global dynamic enp0s8 valid_lft 637sec preferred_lft 637sec inet6 fe80::a00:27ff:fe05:915/64 scope link valid_lft forever preferred_lft forever 4: ovs-system: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN qlen 1000 link/ether a2:26:7b:79:6d:b0 brd ff:ff:ff:ff:ff:ff inet6 fe80::a026:7bff:fe79:6db0/64 scope link valid_lft forever preferred_lft forever 5: br-ex: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN qlen 1000 link/ether ea:ff:61:9b:4e:49 brd ff:ff:ff:ff:ff:ff inet6 fe80::e8ff:61ff:fe9b:4e49/64 scope ... (more)

edit retag flag offensive close merge delete

Comments

What do you mean by "floating ip (master node)"?

I suggest using the network guide to check your configuration. Start at https://docs.openstack.org/neutron/pi... and select the mechanism driver you configured.

Bernd Bausch gravatar imageBernd Bausch ( 2017-09-16 17:21:55 -0600 )edit