Invalid input for field 'identity/password/user/password':

asked 2017-09-13 03:39:09 -0600

liaodalin19903 gravatar image

I have connected the openstack cloud by openstacksdk:

auth_args = {

    print ('before connect')

    connection = connection.Connection(**auth_args)

    conn = singleton.OpenstackConn()
    conn.conn = connection

I have this issue in my project when I access the conn.compute.servers().

HttpException: HttpException: Invalid input for field 'identity/password/user/password': None is not of type 'string' (HTTP 400) (Request-ID: req-7a30ccd1-fd09-4ec8-bb27-e532237d7738), Invalid input for field 'identity/password/user/password': None is not of type 'string'

My code is:

for server in op_conn.conn.compute.servers(): # there comes the error.
    print(" a server ")
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2017-09-13 08:41:42 -0600

brian.curtin gravatar image

I don't have a working keystone v3 cloud to check this on, but I have been told a few times that the *_name fields are supposed to be capital "Default" while the equivalent *_id fields are "default".

Try switching user_domain_name and project_domain_name to be user_domain_id and project_domain_id.

Additionally, I keep seeing your questions in #openstack-sdks but you're never around for the answer. Can you email me at brian at so I can know what you're trying to do here?

edit flag offensive delete link more


Either I change the user_domain_name to user_domain_id or set the default to Default, but all no use, so perhaps I should change the sdk to libcloud which document is ample.

liaodalin19903 gravatar imageliaodalin19903 ( 2017-09-13 21:21:54 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2017-09-13 03:39:09 -0600

Seen: 1,672 times

Last updated: Sep 13 '17