confirm dpdk with openstack

asked 2017-09-12 00:32:53 -0600

ashu gravatar image
 Hi Team

I'm using Openstack Ocata with ubuntu 16.04 using devstack and I want to install Openstack with dpdk environment.Below is my local.conf..

[[local|localrc]]
HOST_NAME=$(hostname)

MYSQL_PASSWORD=ubuntu123

DATABASE_PASSWORD=ubuntu123

RABBIT_PASSWORD=ubuntu123

ADMIN_PASSWORD=ubuntu123

SERVICE_PASSWORD=ubuntu123

HORIZON_PASSWORD=ubuntu123

SERVICE_TOKEN=tokentoken

enable_plugin networking-ovs-dpdk https://github.com/openstack/networking-ovs-dpdk master

OVS_DPDK_MODE=controller_ovs_dpdk

disable_service n-net

enable_service n-cpu

enable_service neutron

enable_service q-svc

enable_service q-agt

enable_service q-dhcp

enable_service q-l3

enable_service q-meta

DEST=/opt/stack

SCREEN_LOGDIR=$DEST/logs/screen

LOGFILE=${SCREEN_LOGDIR}/xstack.sh.log

LOGDAYS=1

Q_ML2_TENANT_NETWORK_TYPE=gre

ENABLE_TENANT_VLANS=False

ENABLE_TENANT_TUNNELS=True

#OVS_TUNNEL_CIDR_MAPPING=br-<device name of NIC for private network, e.g. 'eth1'>:<CIDR of private NIC, e.g. 192.168.20.1/24>

#Example:

#OVS_TUNNEL_CIDR_MAPPING=br-eth1:192.168.20.1/24

OVS_TUNNEL_CIDR_MAPPING=

Q_ML2_PLUGIN_GRE_TYPE_OPTIONS=(tunnel_id_ranges=400:500)

OVS_NUM_HUGEPAGES=3072

OVS_DATAPATH_TYPE=netdev

OVS_LOG_DIR=/opt/stack/logs

#OVS_BRIDGE_MAPPINGS="default:br-<device name of NIC for private network, e.g. 'eth1'>"

#Example:

#OVS_BRIDGE_MAPPINGS="default:br-eth1"

OVS_BRIDGE_MAPPINGS=

MULTI_HOST=1

[[post-config|$NOVA_CONF]]

[DEFAULT]

firewall_driver=nova.virt.firewall.NoopFirewallDriver

novncproxy_host=0.0.0.0

novncproxy_port=6080

scheduler_default_filters=RamFilter,ComputeFilter,AvailabilityZoneFilter,ComputeCapabilitiesFilter,ImagePropertiesFilter,PciPassthroughFilter,NUMATopologyFilter

After running stack.sh,everything comes up and I'm able to open the Openstack dashboard.My query is how I can verify the DPDK installation with the same.

Please let me know.

Regards
Abhishek Jain
edit retag flag offensive close merge delete

Comments

in your loca.conf HOST_IP="a.b.c.d" of ubuntu 16 system is missing.

Praveen N gravatar imagePraveen N ( 2017-09-12 05:10:57 -0600 )edit