Ask Your Question
0

Kolla: Timeout when waiting for Registry To Stop

asked 2017-09-11 06:59:02 -0500

infinitydon gravatar image

updated 2017-09-11 07:00:01 -0500

Hi,

I am trying to setup Openstack Kolla Multi-Node but prechecks is stopping at the error below:

TASK [keystone : Checking free port for Keystone Public] *********************************** fatal: [csky04]: FAILED! => {"changed": false, "elapsed": 1, "failed": true, "msg": "Timeout when waiting for registry_ip_address.69:5000 to stop."} to retry, use: --limit @/usr/share/kolla-ansible/ansible/site.retry

Any idea will be appreciated

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-09-11 09:13:50 -0500

updated 2017-09-11 09:14:12 -0500

Hi,

when using the host where docker registry is running as one of the control nodes, need to change registry bind port to other than 5000, usually we use 4000.

This is due keystone public port 5000 have conflict and cannot bind into this port because is already in use.

Example of making registry run in port 4000

docker run -d \
    --name registry \
    --restart=always \
    -p 4000:5000 \
    -v registry:/var/lib/registry \
    registry:2

Regards

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-09-11 06:59:02 -0500

Seen: 12 times

Last updated: Sep 11