Ask Your Question
0

Can't find package setuptools in requirements

asked 2017-09-09 08:49:35 -0600

sapy45 gravatar image

Hi, I am installing Devstack on ubuntu 16.04. With following error it is exiting.

2017-09-09 13:32:12.569 | + lib/etcd3:install_etcd3:124 : echo '4fde194bbcd259401e2b5c462dfa579ee7f6af539f13f130b8f5b4f52e3b3c52 /home/stack/devstack/files/etcd-v3.1.7-linux-amd64.tar.gz' 2017-09-09 13:32:12.577 | + lib/etcd3:install_etcd3:126 : sha256sum -c /home/stack/devstack/files/etcd.sha256sum 2017-09-09 13:32:12.585 | /home/stack/devstack/files/etcd-v3.1.7-linux-amd64.tar.gz: FAILED 2017-09-09 13:32:12.586 | sha256sum: WARNING: 1 computed checksum did NOT match 2017-09-09 13:32:12.591 | + lib/etcd3:install_etcd3:1 : exit_trap 2017-09-09 13:32:12.596 | + ./stack.sh:exit_trap:493 : local r=1 2017-09-09 13:32:12.606 | ++ ./stack.sh:exit_trap:494 : jobs -p 2017-09-09 13:32:12.614 | + ./stack.sh:exit_trap:494 : jobs= 2017-09-09 13:32:12.621 | + ./stack.sh:exit_trap:497 : [[ -n '' ]] 2017-09-09 13:32:12.627 | + ./stack.sh:exit_trap:503 : '[' -f '' ']' 2017-09-09 13:32:12.634 | + ./stack.sh:exit_trap:508 : kill_spinner 2017-09-09 13:32:12.640 | + ./stack.sh:kill_spinner:407 : '[' '!' -z '' ']' 2017-09-09 13:32:12.646 | + ./stack.sh:exit_trap:510 : [[ 1 -ne 0 ]] 2017-09-09 13:32:12.651 | + ./stack.sh:exit_trap:511 : echo 'Error on exit' 2017-09-09 13:32:12.651 | Error on exit 2017-09-09 13:32:12.659 | + ./stack.sh:exit_trap:512 : generate-subunit 1504963802 130 fail 2017-09-09 13:32:13.221 | + ./stack.sh:exit_trap:513 : [[ -z /opt/stack/logs ]] 2017-09-09 13:32:13.224 | + ./stack.sh:exit_trap:516 : /home/stack/devstack/tools/worlddump.py -d /opt/stack/logs 2017-09-09 13:32:13.817 | + ./stack.sh:exit_trap:522 : exit 1

And /opt/stack/logs/error.log is showing this error, [ERROR] /opt/stack/devstack/inc/python:372 Can't find package setuptools in requirements

I have tried after installing setuptools as well using 'pip install setuptools'

edit retag flag offensive close merge delete

1 answer

Sort by ┬╗ oldest newest most voted
0

answered 2017-11-07 01:52:42 -0600

pike77 gravatar image

do you solve this problem´╝îI am in this trouble too

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-09-09 08:49:35 -0600

Seen: 163 times

Last updated: Sep 09