Could not find a version that satisfies the requirement deprecation>=1.0 (from openstacksdk) (from versions: ) No matching distribution found for deprecation>=1.0 (from openstacksdk)

asked 2017-08-16 07:12:16 -0500

liaodalin19903 gravatar image

When I install the openstacksdk, there comes out an issue:

aircraftdeMacBook-Pro:~ ldl$ sudo pip install openstacksdk
Password:
The directory '/Users/luowensheng/Library/Caches/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
The directory '/Users/luowensheng/Library/Caches/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.
Collecting openstacksdk
  Downloading openstacksdk-0.9.17-py2.py3-none-any.whl (609kB)
    100% |████████████████████████████████| 614kB 9.5kB/s
Requirement already satisfied: jsonpatch>=1.1 in /Library/Python/2.7/site-packages (from openstacksdk)
Collecting keystoneauth1>=2.21.0 (from openstacksdk)
  Downloading keystoneauth1-3.1.0-py2.py3-none-any.whl (271kB)
    100% |████████████████████████████████| 276kB 4.3kB/s
Collecting six>=1.9.0 (from openstacksdk)
  Downloading six-1.10.0-py2.py3-none-any.whl
Collecting pbr!=2.1.0,>=2.0.0 (from openstacksdk)
  Downloading pbr-3.1.1-py2.py3-none-any.whl (99kB)
    100% |████████████████████████████████| 102kB 2.4kB/s
Collecting deprecation>=1.0 (from openstacksdk)
  Could not find a version that satisfies the requirement deprecation>=1.0 (from openstacksdk) (from versions: )
No matching distribution found for deprecation>=1.0 (from openstacksdk)

It says :

Could not find a version that satisfies the requirement deprecation>=1.0 (from openstacksdk) (from versions: ) No matching distribution found for deprecation>=1.0 (from openstacksdk)

edit retag flag offensive close merge delete