packstack --allineone not working

asked 2017-08-09 20:17:52 -0600

Arslaan gravatar image

updated 2017-08-10 08:36:27 -0600

I am trying to setup open stack using packstack but getting errors.

    [root@controller ~]# sudo packstack --gen-answer-file='date +"%d.%m.%y"'.conf
ERROR:root:Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 959, in main
    initPluginsConfig()
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 936, in initPluginsConfig
    plugin.initConfig(controller)
  File "/usr/lib/python2.7/site-packages/packstack/plugins/prescript_000.py", line 407, in initConfig
    "DEFAULT_VALUE": utils.get_localhost_ip(),
  File "/usr/lib/python2.7/site-packages/packstack/installer/utils/network.py", line 45, in get_localhost_ip
    raise NetworkError('Local IP address discovery failed. Please set '
NetworkError: Local IP address discovery failed. Please set a default gateway for your system.


ERROR : Local IP address discovery failed. Please set a default gateway for your system.



[root@controller ~]# ifconfig
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 8  bytes 790 (790.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 8  bytes 790 (790.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

venet0: flags=211<UP,BROADCAST,POINTOPOINT,RUNNING,NOARP>  mtu 1500
        inet 127.0.0.1  netmask 255.255.255.255  broadcast 0.0.0.0  destination 127.0.0.1
        unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  txqueuelen 0  (UNSPEC)
        RX packets 125019  bytes 156201168 (148.9 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 69469  bytes 4512373 (4.3 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

venet0:0: flags=211<UP,BROADCAST,POINTOPOINT,RUNNING,NOARP>  mtu 1500
        inet 54.36.39.24  netmask 255.255.255.255  broadcast 54.36.39.24  destination 54.36.39.24
        unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  txqueuelen 0  (UNSPEC)

[root@controller ~]# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
169.254.0.0     0.0.0.0         255.255.0.0     U     1002   0        0 venet0
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 venet0
edit retag flag offensive close merge delete

Comments

hi, please check interfaces IP. Share the outputs of ifconfig and route -n command

CloudEnthusiast gravatar imageCloudEnthusiast ( 2017-08-09 23:00:43 -0600 )edit

Hi, I have updated the first post with ifconfig & route -n

Arslaan gravatar imageArslaan ( 2017-08-10 08:30:45 -0600 )edit

Gateway is not set. Please configure your network interface properly(file in /etc/sysconfig/network-scripts/ifcfg-<interfacename>) and set gateway. Then run your answer file after making necessary changes.

CloudEnthusiast gravatar imageCloudEnthusiast ( 2017-08-10 23:04:07 -0600 )edit

how you do that? I am new to the hole Linux openstack packstack, I set up GATEWAY=my ip that I found in ifconfig and saved the /etc/sysconfig/network but I still have the same error =(

pelos gravatar imagepelos ( 2017-11-25 01:15:09 -0600 )edit