nova connecting to amqp on 127.0.0.1

asked 2017-08-06 17:00:18 -0500

pacman gravatar image

updated 2017-08-10 06:15:45 -0500

Hi

I tried to setup openstack following the instructions in the getting started guide. OS is Centos7 with all updates applied.

openstack is working, i can spawn instances, create networks and volumes but for some reason there is this message popping up in /var/log/nova/nova-compute.log:

2017-08-06 23:51:18.816 1277 ERROR oslo.messaging._drivers.impl_rabbit [req-7e0a119f-7cf7-45ca-b1be-b0d7319798bb 735e4dd64a0e451bbb5254950af6e6ad f9873284dd3b40edbf9564703c0903ad - - -] [be3fc3c4-2729-4a21-8264-27225e2154f8] AMQP server on 127.0.0.1:5672 is unreachable: [Errno 111] ECONNREFUSED. Trying again in 32 seconds. Client port: None

of course it cannot connect to rabbit on localhost since there is no rabbit running on localhost... but nowhere in my nova config i mentioned localhost. also it has to connect to the configured host (controller) as everything appears to be working besides live migration is not working for some reason ( not sure if it is related )

<edit> by now i figured out that those messages only appear when i try to cold migrate, resize or evacuate a vm. also those operations are stalling forever. i tried creating ssh tunnels to forward the local port to the amqp server and suddenly the messages stopped and the migration finished successfully </edit>

here is my complete /etc/nova/nova.conf:

[root@compute05 ~]# cat /etc/nova/nova.conf
[DEFAULT]
my_ip=10.12.1.25
enabled_apis = osapi_compute,metadata
transport_url = rabbit://openstack:rabbit@controller
use_neutron = True
firewall_driver = nova.virt.firewall.NoopFirewallDriver
[api]
auth_strategy = keystone
[api_database]
[barbican]
[cache]
[cells]
[cinder]
[cloudpipe]
[conductor]
[console]
[consoleauth]
[cors]
[cors.subdomain]
[crypto]
[database]
[ephemeral_storage_encryption]
[filter_scheduler]
[glance]
api_servers = http://controller:9292
[guestfs]
[healthcheck]
[hyperv]
[image_file_url]
[ironic]
[key_manager]
[keystone_authtoken]
auth_uri = http://controller:5000
auth_url = http://controller:35357
#memcached_servers = controller:11211
auth_type = password
project_domain_name = default
user_domain_name = default
project_name = service
username = nova
password = nova
[libvirt]
[matchmaker_redis]
[metrics]
[mks]
[neutron]
url = http://controller:9696
auth_url = http://controller:35357
auth_type = password
project_domain_name = default
user_domain_name = default
region_name = RegionOne
project_name = service
username = neutron
password = neutron
[notifications]
[osapi_v21]
[oslo_concurrency]
lock_path = /var/lib/nova/tmp
[oslo_messaging_amqp]
[oslo_messaging_kafka]
[oslo_messaging_notifications]
[oslo_messaging_rabbit]
[oslo_messaging_zmq]
[oslo_middleware]
[oslo_policy]
[pci]
[placement]
os_region_name = RegionOne
project_domain_name = Default
project_name = service
auth_type = password
user_domain_name = Default
auth_url = http://controller:35357/v3
username = placement
password = placement
[quota]
[rdp]
[remote_debug]
[scheduler]
[serial_console]
[service_user]
[spice]
[ssl]
[trusted_computing]
[upgrade_levels]
[vendordata_dynamic_auth]
[vmware]
[vnc]
enabled = True
vncserver_listen = 0.0.0.0
vncserver_proxyclient_address = $my_ip
novncproxy_base_url = http://controller:6080/vnc_auto.html
[workarounds]
[wsgi]
[xenserver]
[xvp]

any ideas what might be causing this?

edit retag flag offensive close merge delete

Comments

@Bernd Bausch i received an answer to my post per email but it does not show up here - any idea why? i will comment on it shortly since there is some strange behavior related to it which needs longer explanation

pacman gravatar imagepacman ( 2017-08-11 05:39:20 -0500 )edit

I deleted my answer because it turned out it didn't address your problem.

Bernd Bausch gravatar imageBernd Bausch ( 2017-08-11 11:46:04 -0500 )edit