Ask Your Question
0

One of the interface is Build, not Active, others (ha-node2, and ha-node3) all are Active.

asked 2017-08-06 10:24:04 -0500

liaodalin19903 gravatar image

updated 2017-08-06 10:25:18 -0500

I have three nodes to do HA.

One of the interface is Build, not Active, others (ha-node2, and ha-node3) all are Active.

image description

I have checked the below commands:

1) list the namespace

[root@ha-node1 mysql]# ip netns list
qrouter-f0d0305f-73df-4efe-a2a6-ec3102d4570b (id: 0)
qdhcp-8603929d-6d3b-44dd-af59-d9a4f77d4048 (id: 5)
qdhcp-84780518-2e5a-4fc7-8ddb-7cd20e495f6d (id: 4)
qdhcp-c96b9770-1a84-469e-9822-3a3018064d67 (id: 3)
qdhcp-dcbdab02-d9d1-4379-8d1d-28d4df89ca70 (id: 2)
qdhcp-fe5ba835-2d1c-4577-b5b1-4f6631d8d0b9 (id: 1)

2) use the only namespace to ping ips:

[root@ha-node1 mysql]# sudo ip netns exec qrouter-f0d0305f-73df-4efe-a2a6-ec3102d4570b ping baidu.com 
ping: unknown host baidu.com
[root@ha-node1 mysql]# sudo ip netns exec qrouter-f0d0305f-73df-4efe-a2a6-ec3102d4570b ping 192.168.2.1
connect: Network is unreachable
[root@ha-node1 mysql]# sudo ip netns exec qrouter-f0d0305f-73df-4efe-a2a6-ec3102d4570b ping 192.168.2.2
connect: Network is unreachable
[root@ha-node1 mysql]# sudo ip netns exec qrouter-f0d0305f-73df-4efe-a2a6-ec3102d4570b ping 192.168.3.1
connect: Network is unreachable
[root@ha-node1 mysql]# sudo ip netns exec qrouter-f0d0305f-73df-4efe-a2a6-ec3102d4570b ping 192.168.4.1

3) show the namespace ipconfig:

[root@ha-node1 mysql]# sudo ip netns exec qrouter-f0d0305f-73df-4efe-a2a6-ec3102d4570b ifconfig 
ha-fbaa5efe-09: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1450
        inet 169.254.192.1  netmask 255.255.192.0  broadcast 169.254.255.255
        inet6 fe80::f816:3eff:fe64:f674  prefixlen 64  scopeid 0x20<link>
        ether fa:16:3e:64:f6:74  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 7  bytes 738 (738.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

qr-709f617e-9a: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        ether fa:16:3e:ae:1a:30  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2  bytes 188 (188.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

qr-80249b57-91: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1450
        ether fa:16:3e:f4:62:03  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2  bytes 220 (220.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-08-06 13:23:22 -0500

SamYaple gravatar image

Is this a reoccurring issue? Because if this doesn't happen often then the answer is probably rabbitmq. Sometimes messages get lost with rabbitmq. It is possible that is what happened here.

If it is a missing message, then you may not have any errors in any logs.

edit flag offensive delete link more

Comments

@SamYaple How to check if is caused by rabbitmq?

liaodalin19903 gravatar imageliaodalin19903 ( 2017-08-06 21:32:37 -0500 )edit

When this happens, do you see "timeout waiting for reply" messages in the nova or neutron logs?

What do the nova compute and scheduler logs have to say about this instance?

SamYaple gravatar imageSamYaple ( 2017-10-26 23:38:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-08-06 10:24:04 -0500

Seen: 51 times

Last updated: Aug 06 '17