kolla-openstack multinode 'No valid host was found.'

asked 2017-08-04 13:10:58 -0500

Thanks to all the help so far I am now to the point of trying to create a test virtual server in the openstack environment deployed using kolla-ansible. I have a single controller node and a single compute node.

This is similiar scenario to the question below but different error: https://ask.openstack.org/en/question/107905/kolla-openstack-getting-error-no-valid-hosts-found-error-when-i-try-to-create-a-vm-in-mutinode-env/ (https://ask.openstack.org/en/question...)

I have followed the kolla-ansible Quick Start guide to the end and have set up the networks and other things done in the init-runonce file.

When I try to create my first VM I get an error. (openstack server create command completes then there is an error message when I do openstack server list demo1.)

{u'message': u'No valid host was found. There are not enough hosts available.', u'code': 500, u'details': u'  File "/usr/lib/python2.7/dist-packages/nova/conductor/manager.py", line 526, in build_instances
    context, request_spec, filter_properties)
  File "/usr/lib/python2.7/dist-packages/nova/conductor/manager.py", line 597, in _schedule_instances
    hosts = self.scheduler_client.select_destinations(context, spec_obj)
  File "/usr/lib/python2.7/dist-packages/nova/scheduler/utils.py", line 371, in wrapped
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/nova/scheduler/client/__init__.py", line 51, in select_destinations
    return self.queryclient.select_destinations(context, spec_obj)
  File "/usr/lib/python2.7/dist-packages/nova/scheduler/client/__init__.py", line 37, in __run_method
    return getattr(self.instance, __name)(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/nova/scheduler/client/query.py", line 32, in select_destinations
    return self.scheduler_rpcapi.select_destinations(context, spec_obj)
  File "/usr/lib/python2.7/dist-packages/nova/scheduler/rpcapi.py", line 129, in select_destinations
    return cctxt.call(ctxt, \'select_destinations\', **msg_args)
  File "/usr/lib/python2.7/dist-packages/oslo_messaging/rpc/client.py", line 169, in call
    retry=self.retry)
  File "/usr/lib/python2.7/dist-packages/oslo_messaging/transport.py", line 97, in _send
    timeout=timeout, retry=retry)
  File "/usr/lib/python2.7/dist-packages/oslo_messaging/_drivers/amqpdriver.py", line 458, in send
    retry=retry)
  File "/usr/lib/python2.7/dist-packages/oslo_messaging/_drivers/amqpdriver.py", line 449, in _send
    raise result
', u'created': u'2017-08-03T18:38:17Z'} |

I'm thinking this is either a networking problem or a KVM/QEMU mismatch but I don't really know how to debug. In the docker world it's not obvious to me which of the containers are doing what and how I can do simple nova or neutron commands.

The compute node, nova-compute container, shows KVM should be available:

# egrep -c '(vmx|svm)' /proc/cpuinfo
88

The compute node log: nova-compute.log is excerpted below:

2017-08-04 11:04:25.724 7 INFO nova.compute.resource_tracker [req-5457afa5-46c6-4db8-be7f-18bd86234685 - - - - -] Final resource view: name=mgwlab7.intel.com phys_ram=128821MB used_ram=512MB phys_disk=790GB used_disk=0GB total_vcpus=88 used_vcpus=0 pci_stats=[]
2017-08-04 11:05:26.932 7 INFO nova.compute.resource_tracker [req-5457afa5-46c6-4db8-be7f-18bd86234685 - - - - -] Final resource view: name=mgwlab7.intel.com phys_ram=128821MB used_ram=512MB phys_disk=790GB used_disk=0GB total_vcpus=88 used_vcpus=0 pci_stats=[]
2017-08-04 11:06:14.810 7 INFO nova.compute.claims [req-3dbb5882-9fbb-448c-beec-d575473b4771 893b682df7564737862fdb0ad6933c9e ...
(more)
edit retag flag offensive close merge delete

Comments

look like selinux blocking libvirt, kolla does not support selinux enabled

Eduardo Gonzalez gravatar imageEduardo Gonzalez ( 2017-08-10 04:51:10 -0500 )edit

thanks for taking the time to respond. I'll investigate what to do next.

markhargrove28 gravatar imagemarkhargrove28 ( 2017-08-10 12:18:52 -0500 )edit

I didn't think I had enabled selinux on the compute node (or any of the nodes). When I check I find it is not enabled.

root@mgwlab7:~# selinuxenabled && echo enabled || echo disabled

disabled

markhargrove28 gravatar imagemarkhargrove28 ( 2017-08-10 15:24:52 -0500 )edit

Any other suggestions? the compute node is running Ubuntu 16.04 on an 88 core machine. Intel(R) Xeon(R) CPU E5-2699 v4 @ 2.20GHz

markhargrove28 gravatar imagemarkhargrove28 ( 2017-08-11 08:50:30 -0500 )edit