haproxy[1387]: proxy nova_compute_api_cluster has no server available!

asked 2017-08-04 12:18:07 -0500

liaodalin19903 gravatar image

I want to restart the nova related services:

[root@ha-node1 nova]# systemctl restart openstack-nova-api.service openstack-nova-cert.service openstack-nova-consoleauth.service openstack-nova-scheduler.service openstack-nova-conductor.service openstack-nova-novncproxy.service

But can not start the below red or yellow status node services:

image description

The print out is below:

 [root@ha-node1 nova]# systemctl restart openstack-nova-api.service openstack-nova-cert.service openstack-nova-consoleauth.service openstack-nova-scheduler.service openstack-nova-conductor.service openstack-nova-novncproxy.service
[root@ha-node1 nova]# 
Message from syslogd@localhost at Aug  5 01:02:14 ...
 haproxy[1387]: proxy nova_compute_api_cluster has no server available!

Message from syslogd@localhost at Aug  5 01:03:17 ...
 haproxy[1387]: proxy nova_compute_api_cluster has no server available!

Message from syslogd@localhost at Aug  5 01:04:22 ...
 haproxy[1387]: proxy nova_compute_api_cluster has no server available!

Message from syslogd@localhost at Aug  5 01:05:23 ...
 haproxy[1387]: proxy nova-metadata-api_cluster has no server available!

Message from syslogd@localhost at Aug  5 01:06:15 ...
 haproxy[1387]: proxy nova_compute_api_cluster has no server available!

Message from syslogd@localhost at Aug  5 01:06:38 ...
 haproxy[1387]: proxy nova_compute_api_cluster has no server available!

Message from syslogd@localhost at Aug  5 01:06:59 ...
 haproxy[1387]: proxy nova_compute_api_cluster has no server available!

Message from syslogd@localhost at Aug  5 01:07:39 ...
 haproxy[1387]: proxy nova_compute_api_cluster has no server available!

Message from syslogd@localhost at Aug  5 01:09:01 ...
 haproxy[1387]: proxy nova_compute_api_cluster has no server available!

Message from syslogd@localhost at Aug  5 01:09:46 ...
 haproxy[1387]: proxy nova-metadata-api_cluster has no server available!
edit retag flag offensive close merge delete

Comments

It would seem that nova-api and nova-metadata don't start on the red and yellow nodes. Check the nova-api and nova-metadata log files on those nodes.

Connectivity to those servers might be a problem as well. Perhaps the firewall.

Bernd Bausch gravatar imageBernd Bausch ( 2017-08-05 20:42:19 -0500 )edit

Disclaimer: I know close to nothing about OpenStack HA but your question helps me to learn about it.

Bernd Bausch gravatar imageBernd Bausch ( 2017-08-05 20:43:22 -0500 )edit