Ask Your Question
0

My image status in the Dashbord always is already line up.

asked 2017-08-04 01:43:01 -0500

liaodalin19903 gravatar image

updated 2017-08-04 03:20:58 -0500

My image status in the Dashbord always is already line up.

image description

In the VM I use command to list it, it is exists:

[root@ha-node1 neutron]# glance image-list 
+--------------------------------------+---------------------+
| ID                                   | Name                |
+--------------------------------------+---------------------+
| 303f912b-a7e6-45f8-8219-7dc406d8e111 | cirros-0.3.4-x86_64 |
+--------------------------------------+---------------------+

And if I create instance form the dashboard, there is not image.

enter image description here


EDIT-1

This is the api.log:

2017-08-04 15:52:02.981 3942 INFO eventlet.wsgi.server [-] 192.168.8.103 - - [04/Aug/2017 15:52:02] "OPTIONS / HTTP/1.0" 200 94 0.001607
2017-08-04 15:52:06.281 3942 INFO eventlet.wsgi.server [-] 192.168.8.104 - - [04/Aug/2017 15:52:06] "OPTIONS / HTTP/1.0" 200 94 0.001733
2017-08-04 15:52:08.477 3943 INFO eventlet.wsgi.server [-] 192.168.8.102 - - [04/Aug/2017 15:52:08] "OPTIONS / HTTP/1.0" 200 94 0.001755
2017-08-04 15:52:12.983 3943 INFO eventlet.wsgi.server [-] 192.168.8.103 - - [04/Aug/2017 15:52:12] "OPTIONS / HTTP/1.0" 200 94 0.001562

EDIT-2

[root@ha-node2 glance]# cd /var/lib/glance/images/
[root@ha-node2 images]# ls
[root@ha-node2 images]#

And in the cd /var/lib/glance/images/, there is no file in it.

edit retag flag offensive close merge delete

Comments

What does the glance api and registry logs says?

Praveen N gravatar imagePraveen N ( 2017-08-04 02:26:56 -0500 )edit

@PraveenN see my edit-1

liaodalin19903 gravatar imageliaodalin19903 ( 2017-08-04 02:53:19 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-08-04 04:44:55 -0500

liaodalin19903 gravatar image

Finally I solved it.

  1. ensure the image file permission to be glance:glance:

    chown glance:glance cirros-0.3.4-x86_64-disk.img

  2. ensure the image store directory permission to glance:glance:

    chown -R glance:glance /var/lib/glance/images

  3. In the /etc/glance/glance-api.conf:

    under the [glance_store], the stores I changed to this:

    stores = file,http,glance.store.filesystem.Store,glance.store.http.Store

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-08-04 01:43:01 -0500

Seen: 37 times

Last updated: Aug 04 '17