Ask Your Question
0

gnocchi-api running error, Address already in use

asked 2017-08-03 22:37:30 -0500

accjiyun gravatar image

When i install Ceilometer and on the stage of "Verify operation" on OpenStack Installation Tutorials, i run command following,But it's not success.

[root@controller3 gnocchi]# gnocchi resource list  --type image
Unable to establish connection to http://localhost:8041/v1/resource/image?: HTTPConnectionPool(host='localhost', port=8041): Max retries exceeded with url: /v1/resource/image (Caused by NewConnectionError('<requests.packages.urllib3.connection.HTTPConnection object at 0x2ff4950>: Failed to establish a new connection: [Errno 111] Connection refused',))

When i finished the gnocchi installation and run gnocchi-upgrade, that's all right. But next, when i run gnocchi-api, the gnocchi-api.log show WSGI Address already in use. Could you tell me how to solve it ? Thanks !

gnocchi-api.log:

2017-08-03 21:40:09,020 [6098] DEBUG    gnocchi.service: ********************************************************************************
2017-08-03 21:40:09,021 [6098] DEBUG    gnocchi.service: Configuration options gathered from:
2017-08-03 21:40:09,021 [6098] DEBUG    gnocchi.service: command line args: []
2017-08-03 21:40:09,021 [6098] DEBUG    gnocchi.service: config files: ['/etc/gnocchi/gnocchi.conf']
2017-08-03 21:40:09,021 [6098] DEBUG    gnocchi.service: ================================================================================
2017-08-03 21:40:09,021 [6098] DEBUG    gnocchi.service: config_dir                     = []
2017-08-03 21:40:09,021 [6098] DEBUG    gnocchi.service: config_file                    = ['/etc/gnocchi/gnocchi.conf']
2017-08-03 21:40:09,021 [6098] DEBUG    gnocchi.service: debug                          = True
2017-08-03 21:40:09,021 [6098] DEBUG    gnocchi.service: log_dir                        = /var/log/gnocchi
2017-08-03 21:40:09,021 [6098] DEBUG    gnocchi.service: log_file                       = None
2017-08-03 21:40:09,021 [6098] DEBUG    gnocchi.service: syslog_log_facility            = user
2017-08-03 21:40:09,021 [6098] DEBUG    gnocchi.service: use_journal                    = False
2017-08-03 21:40:09,022 [6098] DEBUG    gnocchi.service: use_syslog                     = False
2017-08-03 21:40:09,022 [6098] DEBUG    gnocchi.service: verbose                        = True
2017-08-03 21:40:09,022 [6098] DEBUG    gnocchi.service: statsd.archive_policy_name     = low
2017-08-03 21:40:09,022 [6098] DEBUG    gnocchi.service: statsd.creator                 = :
2017-08-03 21:40:09,022 [6098] DEBUG    gnocchi.service: statsd.flush_delay             = 10.0
2017-08-03 21:40:09,023 [6098] DEBUG    gnocchi.service: statsd.host                    = controller3
2017-08-03 21:40:09,023 [6098] DEBUG    gnocchi.service: statsd.port                    = 8125
2017-08-03 21:40:09,023 [6098] DEBUG    gnocchi.service: statsd.project_id              = None
2017-08-03 21:40:09,023 [6098] DEBUG    gnocchi.service: statsd.resource_id             = 83746b69-87e8-4ee2-b9af-39769cc32b75
2017-08-03 21:40:09,023 [6098] DEBUG    gnocchi.service: statsd.user_id                 = None
2017-08-03 21:40:09,023 [6098] DEBUG    gnocchi.service: incoming.ceph_conffile         = /etc/ceph/ceph.conf
2017-08-03 21:40:09,023 [6098] DEBUG    gnocchi.service: incoming.ceph_keyring          = 
2017-08-03 21:40:09,024 [6098] DEBUG    gnocchi.service: incoming.ceph_pool             = gnocchi
2017-08-03 21:40:09,024 [6098] DEBUG    gnocchi.service: incoming.ceph_secret           = ****
2017-08-03 21:40:09,024 [6098] DEBUG    gnocchi.service: incoming.ceph_timeout          = 30
2017-08-03 21:40:09,024 [6098] DEBUG    gnocchi.service: incoming.ceph_username         = 
2017-08-03 21:40:09,024 [6098] DEBUG    gnocchi.service: incoming.driver                = file
2017-08-03 21:40:09,024 [6098] DEBUG    gnocchi.service: incoming.file_basepath         = /var/lib/gnocchi
2017-08-03 21:40:09,025 [6098] DEBUG    gnocchi.service: incoming.redis_url             = redis://localhost:6379/
2017-08-03 21:40:09,025 [6098] DEBUG    gnocchi.service: incoming.s3_access_key_id      = 
2017-08-03 21:40:09 ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2017-10-12 11:10:53 -0500

Paul Bourke gravatar image

For your first issue, make sure the env variable OS_AUTH_URL is set correctly:

export OS_AUTH_URL=http://controller3:35357/v3

The 'Address already in use' error simply means gnocchi is already running. If you wish to restart it you should first kill off the existing process, using something like:

pkill gnocchi
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2017-08-03 22:37:30 -0500

Seen: 126 times

Last updated: Oct 12