Ask Your Question
0

RDO Mitaka instance boot error

asked 2017-08-02 03:16:51 -0600

Sandi gravatar image

updated 2017-08-03 14:46:46 -0600

rbowen gravatar image

I used RHEL 7.2 for RDO Mitaka installation according to the guide mention here in (https://docs.openstack.org/mitaka/ins...) . I verified all the steps one by one no error till the end. Instance created by dashboard, while take console of the VM its showing boot error and instance stuck also the compute node gets pause. Error showing

SeaBIOS (version 1.9.1-5.el7_3.3) Machine UUID .... .... iPXE (http://ipxe.org) 00:03.0 C980 PCI2.10 PnP PMM.

I am using QEMU 1.5.3( Latest Version) and RHEL kernel version 3.10.0-327

in nova.conf file virt_type = qemu

How can I solve this problem? (I have tried on cirros, rhel and ubuntu qcow2 demo image from Openstack, and same result). Nova compute node only showing warning i.e

WARNING nova.virt.libvirt.driver [req-7bb64e56-a819-4cbb-aa79-8587a774c5f3 - - - - -] couldn't obtain the vcpu count from domain id: 0962550a-634e-472e-b6d6-51f9c27aa246, exception: Requested operation is not valid: cpu affinity is not supported

virsh version Compiled against library: libvirt 2.0.0 Using library: libvirt 2.0.0 Using API: QEMU 2.0.0 Running hypervisor: QEMU 1.5.3 Please suggest me i got stuck.

Thanks.

edit retag flag offensive close merge delete

Comments

what does nova-compute log says?

CloudEnthusiast gravatar imageCloudEnthusiast ( 2017-08-03 06:45:26 -0600 )edit

@CloudEnthusiast

Nova compute node only showing warning i.e

WARNING nova.virt.libvirt.driver [req-7bb64e56-a819-4cbb-aa79-8587a774c5f3 - - - - -] couldn't obtain the vcpu count from domain id: 0962550a-634e-472e-b6d6-51f9c27aa246, exception: Requested operation is not valid: cpu affinity is not s

Sandi gravatar imageSandi ( 2017-08-03 08:37:33 -0600 )edit

If you can't fit the entire log entry in your comment field, please edit your original post and add it there. Thanks.

rbowen gravatar imagerbowen ( 2017-08-03 14:47:38 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2017-08-03 05:43:47 -0600

Shaik Saddam Hussain gravatar image

Try with virt_type = kvm in nova.conf file and restart all nova services

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2017-08-02 03:08:52 -0600

Seen: 109 times

Last updated: Aug 03 '17